5 Replies Latest reply on Feb 28, 2014 1:25 PM by Peter Arcuri

    Error when installing keys using Mx Secure Storage

      Hi

      I have already installed Mx Multi-User login with Data Separation on a TC55 terminal and it is now up and running.

      However, when I want to enable Mx Secure Storage I am not able to install the key on the device.

      I have tried using both manual and import modes. Despite the fact that a message turns up saying that the key was successfully installed, when I try to list the keys installed, the list is empty. Moreover, if I try to create a volume, the app tells me that there is no key installed, so I'm pretty sure it was not installed at all. I am logged in as an Administrator and I am using an SD card to load files in the app. As I said, I have tried using both manual and import modes: in the manual mode, I write "key1(space)(the 64 hexadecimal key)" and in the import mode, I create a file called "keyfile" stored in /sdcard/ with the same string in it. The result is exactly the same. Has anybody come across this scenario? I am following TC55's Integrator Guide, Chapter 5, but it is not as useful as I would like it to be. Any ideas will be much appreciated!