:test: environment in settings.yml doesn't work

Hi,

After doing some heavy testing I came to the conclusion that the name :test: as a environment setting is not allowed inside settings.yml. The thin socket will die after receiving a request from nginx it if this environment name is used.

Changing it to ":testing:" will get things working again.

thin.0.log:

    ...

    Unexpected error while processing request: can't yield from root fiber

Is this probably because "test" is a reserved word in ruby?

Thanks.

Kutir Mobility
Nice find RubenI think its a

Nice find Ruben

I think its a bug. Lets wait to hear from Motorola.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Ruben Ruben
Thanks, i'll be following

Thanks, i'll be following this thread.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Mark Mayer
What the heck Moto!? We too

What the heck Moto!? We too just went through some major hair pulling on this one as well.  Even Sinatra's environmental documentation says to do the same thing: Sinatra: Configuring Settings under "Built-in Settings".

Changed test environment to anything other than "test" and it works, thanks Ruben Ruben for pointing this one out.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Ruben Ruben
No problem, happy to help.It

No problem, happy to help.

It doesn't seem to be anything ruby-related (contrary to what I said in my first post), but since sinatra's docs also suggest this, i'm wondering if its a Moto bug, or something upstream.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments