3 Replies Latest reply on Apr 7, 2014 4:50 AM by BHAKTA RANJAN SATAPATHY

    New project creation gives error in mac

    Santhosh Kumar

      I am new to rhomobile development. I installed Rhomobile as per the document in Rhomobile site. But when i try to create an Rhomobile project it gives the following error.  `require': cannot load such file -- iconv (LoadError)

       

       

      Last login: Sat Apr  5 13:47:45 on ttys000
      People-Infosoft-santhoshs-Mac-mini:~ santhosh$ /Applications/Motorola\ RhoStudio/RhoStudio\ 32\ bits ; exit;

      Select Ruby version to start RhoStudio:
      1) ruby-2.1.1
      2) ruby-2.1.1@global
      #?

       


      PWD: /Users/santhosh/workspace
      CMD: rhodes app RhoMobileApplication1
      /Users/santhosh/.rvm/rubies/ruby-2.1.1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:126:in `require': cannot load such file -- iconv (LoadError)
      from /Users/santhosh/.rvm/rubies/ruby-2.1.1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:126:in `require'
      from /Users/santhosh/.rvm/gems/ruby-2.1.1/gems/activesupport-2.3.18/lib/active_support/inflector.rb:3:in `<top (required)>'
      from /Users/santhosh/.rvm/rubies/ruby-2.1.1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:73:in `require'
      from /Users/santhosh/.rvm/rubies/ruby-2.1.1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:73:in `require'
      from /Users/santhosh/.rvm/gems/ruby-2.1.1/gems/activesupport-2.3.18/lib/active_support/core_ext/integer/inflections.rb:1:in `<top (required)>'
      from /Users/santhosh/.rvm/rubies/ruby-2.1.1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:73:in `require'
      from /Users/santhosh/.rvm/rubies/ruby-2.1.1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:73:in `require'
      from /Users/santhosh/.rvm/gems/ruby-2.1.1/gems/activesupport-2.3.18/lib/active_support/core_ext/integer.rb:2:in `<top (required)>'
      from /Users/santhosh/.rvm/rubies/ruby-2.1.1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:73:in `require'
      from /Users/santhosh/.rvm/rubies/ruby-2.1.1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:73:in `require'
      from /Users/santhosh/.rvm/gems/ruby-2.1.1/gems/activesupport-2.3.18/lib/active_support/core_ext.rb:8:in `block in <top (required)>'
      from /Users/santhosh/.rvm/gems/ruby-2.1.1/gems/activesupport-2.3.18/lib/active_support/core_ext.rb:8:in `each'
      from /Users/santhosh/.rvm/gems/ruby-2.1.1/gems/activesupport-2.3.18/lib/active_support/core_ext.rb:8:in `<top (required)>'
      from /Users/santhosh/.rvm/rubies/ruby-2.1.1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:73:in `require'
      from /Users/santhosh/.rvm/rubies/ruby-2.1.1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:73:in `require'
      from /Users/santhosh/.rvm/gems/ruby-2.1.1/gems/activesupport-2.3.18/lib/active_support.rb:56:in `<top (required)>'
      from /Users/santhosh/.rvm/rubies/ruby-2.1.1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:73:in `require'
      from /Users/santhosh/.rvm/rubies/ruby-2.1.1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:73:in `require'
      from /Users/santhosh/.rvm/gems/ruby-2.1.1/gems/rhodes-4.0.0/raes/generators/rhogen.rb:6:in `<top (required)>'
      from /Users/santhosh/.rvm/rubies/ruby-2.1.1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:126:in `require'
      from /Users/santhosh/.rvm/rubies/ruby-2.1.1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:126:in `require'
      from /Users/santhosh/.rvm/gems/ruby-2.1.1/gems/rhodes-4.0.0/bin/rhogen:5:in `<top (required)>'
      from /Users/santhosh/.rvm/gems/ruby-2.1.1/gems/rhodes-4.0.0/bin/rhodes:4:in `load'
      from /Users/santhosh/.rvm/gems/ruby-2.1.1/gems/rhodes-4.0.0/bin/rhodes:4:in `<top (required)>'
      from /Users/santhosh/.rvm/gems/ruby-2.1.1/bin/rhodes:23:in `load'
      from /Users/santhosh/.rvm/gems/ruby-2.1.1/bin/rhodes:23:in `<main>'
      from /Users/santhosh/.rvm/gems/ruby-2.1.1/bin/ruby_executable_hooks:15:in `eval'
      from /Users/santhosh/.rvm/gems/ruby-2.1.1/bin/ruby_executable_hooks:15:in `<main>'
      RET: 1


      The frst 7 lines is thrown in command window when opening rhostudio. all the remaining errors are thrown in the Rhostuiod console window when creating a new rhomobile project.

       

      Please any one help me on this?

       

      Thanks

      Santhosh Kumar S