2 Replies Latest reply on Apr 8, 2014 12:14 AM by Tuomas Määttä

    Volume adjustment disabled in OS after launching RhoElements

    Tuomas Määttä

      We use RhoElements 4.0 as a webkit for html5 enabled web browser and we are currently using WEH 6.5.3 devices (MC45 and MC65). Hardware volume keys does not function after RhoElements is launched for the first time, even if the RhoElements is closed. Before RhoElements is launched the volume keys operate normally. What disables the volume controls.

       

      In the config.xml I used the following settings:

        <DeviceKeys>
          <FunctionKeysCapturable      value="0"/>
          <EnableFunctionKey_F1     value="0"/>
          <EnableFunctionKey_F2     value="0"/>
          <EnableFunctionKey_F3     value="0"/>
          <EnableFunctionKey_F4     value="0"/>
          <EnableFunctionKey_F5     value="0"/>
          <EnableFunctionKey_F6     value="1"/>
          <EnableFunctionKey_F7     value="1"/>
          <EnableFunctionKey_F8     value="0"/>
          <EnableFunctionKey_F9     value="0"/>
          <EnableFunctionKey_F10    value="0"/>
          <EnableFunctionKey_F11    value="0"/>
          <EnableFunctionKey_F12    value="0"/>
          <EnableApplicationKey_A1  value="0"/>
          <EnableApplicationKey_A2  value="0"/>
          <EnableApplicationKey_A3  value="0"/>
          <EnableApplicationKey_A4  value="0"/>
          <EnableApplicationKey_A5  value="0"/>
          <EnableApplicationKey_A6  value="0"/>
          <EnableApplicationKey_A7  value="0"/>
          <EnableApplicationKey_A8  value="0"/>
        </DeviceKeys>