8 Replies Latest reply on Dec 15, 2014 6:04 AM by Jan van Dijk

    Updating Android native extension from v4.0 to v4.1

    Pietro Francesco Maggi

      I've a project built with RMS v4.0 containing two Android extension.

       

      Trying to recompile the project with RMS v4.1 report some error building my extensions:

       

      Tasks: TOP => default => /Users/rhomobile/workspace/REHC/bin/target/android/release/extensions/externalstorage/libexternalstorage.a => build => config

      rake aborted!

      Command failed with status (1): [$SHELL ./build arm...]

      /Users/rhomobile/.rvm/gems/ruby-1.9.3-p545/gems/rake-10.1.1/lib/rake/file_utils.rb:55:in `block in create_shell_runner'

      /Users/rhomobile/.rvm/gems/ruby-1.9.3-p545/gems/rake-10.1.1/lib/rake/file_utils.rb:45:in `call'

      /Users/rhomobile/.rvm/gems/ruby-1.9.3-p545/gems/rake-10.1.1/lib/rake/file_utils.rb:45:in `sh'

      /Users/rhomobile/.rvm/gems/ruby-1.9.3-p545/gems/rake-10.1.1/lib/rake/file_utils_ext.rb:37:in `sh'

       

      There's any easy way to update an Android native extension from v4.0 to v4.1?

      Is it possible to have the same extension compiling with v4.0 and v4.1?

       

      ~Pietro