Setting the Date and Time on an SB1

Setting the Date and Time on an SB1.  There are many ways to set the date and time
on an SB1.  One way is to set it with the Fusion settings.  When you create a
Fusion Profile in MSP the Fusion Option is set by default.  This will set the date and time based off the
Wireless infrastructure.  If you are using Motorola Solutions Infrastructure it will set the date and time.

 

On the device to set the date and time manually the user will need to set it through the GUI in advanced  settings under Set Date and Time.

Comments


I've been doing a lot of work trying to get the date, time and time zone set on the SB1 with mixed results.

First we have to assume the wireless infrastructure will not support setting of the time.  I have found two registry files that when placed in the root of the userdrive will set the date/time/zone.

First was found with a utilities download. Here is the link to the post. https://developer.motorolasolutions.com/message/16425#16425

In the utilities folder is a SETDEFAULTTZ.REG file to set the time zone.  You have to manually set the time zone in the top of the file like this

[HKEY_LOCAL_MACHINE\Time Zones]

    @="Eastern Standard Time"

This will set the time zone to GMT-5

To deploy you have to copy the four files specified to the user drive of the SB1 and upon reboot the time zone is set to what you indicated above.

This works, however, it does not take into account daylight savings time.  So twice a year you have to manually change the time zone.

I tried to do this with RDT Solo but am having no luck deploying a REG file to the root of the userdrive. It gives me a cant create file error.  I suspect the reg file is set to read only and cant be overwritten.

Any help on this would be great.

The second file sets the system to sync the time to an internet time server, specifically these two tock.usno.navy.mil and time.windows.com

To use create a TIMESRV.REG file using notepad or your favorite text editor and copy the following.

[HKEY_LOCAL_MACHINE\Services\TIMESVC]

"Keep"=dword:00000001

"Context"=dword:00000000

"Dll"="timesvc.dll"

"Order"=dword:00000099

"Prefix"="NTP"

"Index"=dword:00000000

"server"=hex(7):\

74,6f,63,6b,2e,75,73,6e,6f,2e,6e,61,76,79,2e,6d,69,6c,00,74,69,6d,65,2e,77,\

69,6e,64,6f,77,73,2e,63,6f,6d,00,00

"AutoUpdate"=dword:00000001

"ServerRole"=dword:00000001

"refresh"=dword:48190800

"recoveryrefresh"=dword:05265c00

"threshold"=dword:05265c00

"trustlocalclock"=dword:00000000



The server value is ascii characters for the digits server names separated by a null, then terminated with 2 nulls.

Save the .REG file to the root userdrive and reboot.  As long as you have access outside the firewall for NTP time and these web addresses then the date and time will be set.


If your time zone was set properly with the first REG file then the time will also display properly.


The problem I have us the same as the first issue, i cant automate the deploy via RDT Solo. 


Honestly It would be best if daylight savings time was taken into account with the time zone entry but if i can get the deployment working through RDT Solo then this is a workable solution.




Dear Myk,

I tried putting the file below (named TIMESRV.REG) in the root of the UserDrive but, after reboot, nothing had changed... Any idea what I'm doing wrong?

[HKEY_LOCAL_MACHINE\Services\TIMESVC]

"Keep"=dword:00000001

"Context"=dword:00000000

"Dll"="timesvc.dll"

"Order"=dword:00000099

"Prefix"="NTP"

"Index"=dword:00000000

"server"=hex(7):6e,74,70,2e,74,65,6c,65,6e,65,74,2e,62,65,00,00

"AutoUpdate"=dword:00000001

"ServerRole"=dword:00000001

"refresh"=dword:48190800

"recoveryrefresh"=dword:05265c00

"threshold"=dword:05265c00

"trustlocalclock"=dword:00000000

Thanks,

E

UPDATE 1: I tried the REG file in the dev toolbox; that one seems to work flawlessly... still none the wiser as to why the code above fails, though...

UPDATE 2: Painful little detail after initial euphoria due to UPDATE 1: Even though the device asks and gets the correct time from the time server I chose, I'm still getting a result which is off by 9 hours because of the default GMT-8 time zone setting. I've tried to change that too (following the instructions in DT2.4.0), but no luck so far...


Yes I did, even before it worked, so that (alone) didn't do the trick.

I got it working in the end, however, but I don't remember how exactly.

After all, you just reacted to a post over a year old


But you solved your problem too? If not, what can I (try and) help you with?


Did you warmboot the device after initial coldboot and reg merge?


I do that a lot . I was looking for answer and found this thread so I tried to ask as I got similar problem on CE7.0


I've solved it with RemCapture. But thank you