Android ZSDK Bluetooth BTLE ISSUES

I'm trying to add BLE (Bluetooth Low Energy) support to our Android product. It currently works with Classic mode without issue but this may not be possible with our next project.

I wanted to do some basic testing using the Zebra demo app first so I've downloaded the Zebra Android BLE demo which uses the BTLE lib. ZSDK_ANDROID_BTLE.jar (Version v2.14.5198). It works very poorly compared to Classic mode. I can get it to print a test label probably 1 time in 20 attempts.

The following are the steps I have been following:

I setup a fresh Factory Reset ZQ610 printer with the following Bluetooth settings. (Using Zebra Setup Utilities)

Enabled: (Ticked)
Friendly Name:
Discoverable: On
Minimum Security Mode: 1
Authentication pin:
Bonding: On
Enable Reconnect: iOS Only
Pairing Method: Just Works
Bluetooth Controller Mode: Low Energy (Also tried "Classic and Low Energy")

Press Next

Minimum Security Mode: None
Pairing Method: Use Printer Settings

Press Finish (Printer Resets, unplug USB cable)

I then run the Zebra Android demo app (ZSDK Ble Dev Demos)

Select Menu Option 1 (Connectivity)
Press Discover Printers button...(Correct Printer is shown in list)
Select the printer.

Probably 1 or 2 times in 20 it will connect and print the test label. The rest all fail with "no connection" type errors.

I've tried this on a TC20, TC51, One Plus 3. All with Bluetooth switched on and all with the same result.

I can see various other similar support queries about Android and Zebra BLE printers but there doesn't seem to be any response.

Could someone at Zebra please try following the same steps as above and confirm if they have the same issue.

Please contact me if you require any further information.

Thanks

Paul

Alexander Palchikov
Hi Paul,Could you please

Hi Paul,

Could you please share the following information:

 

Alexander Palchikov
Software Engineer, Kutir Mobility
Posted on behalf of Zebra Technologies

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Paul Sage
Hi Alexander, my printer was

Hi Alexander, my printer was was upgraded a couple of months ago to V85.20.19Z. (ZQ610 SN: XXZJJ183202995)

TC20 is running Android 8.1.0
TC51 is running Android 6
One Plus 3 is running 9

I don't see anything related to a fix in the firmware release notes but I will update the printer firmware and retest.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments