Action-Certificate is not installed (enroll device to Workspace One)

Hi,
I'm trying enroll MC903B device to Workspace One but receive issue:
"Last Staging Error
Error #1
Setting Type
Intent
Original Error Message
exception, Action-Certificate is not installed."

I use StageNow BarCode generated by WS1.
The process on device looks as describe:
Open StageNow app and get admin access
Scan 3 barcodes that have been generated by WS1.
Staging In progress
Downloading Airwatch agent
Staging in progress
Barcode Staging Error (up to get details).

Any idea what I'm doing wrong? I'm the new one in Android and Zebra devices :) Please help :)

Attachments: 
Larry Stanton
Response

Did you ever get a response to this? Or figure out what was wrong? I'm getting this too.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Mathias Lorson
I have the same problem with

I have the same problem with an Zebra TC77 runnign Android 10 and Airwatch.
Airwatch Agent package is updated to v 20.11.0.20_5.1.0.3_4.3.1_1.3
-> Airwatch 20.11.0.20
-> MX Services 5.1.0.3

StageNow shows

Last Staging Error, Error #1, Setting Type Intent, Original Error Message : exception, Action-certificate is not installed.

Did anyone solve this, so please give me a hint :)

Thx

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Darryn Campbell
Generally this error comes

Generally this error comes using Zebra stagenow enrollment when another app is installed before agent apk. Its an mandated that agent (DPC) Should be the first installed user app on device.

If its not the case ( ie agent app is not first user installed app on device) then enrollment procedures ask for additional certificates same as DA to DO enrollment case

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Mathias Lorson
Hello Darryn,

Hello Darryn,

thanks for your reply.

In my scenario I use a brand new device, launch the enterprise launcher, connect to WIFI and open stage now.
The Airwatch Agent is bundled with Zebra MX services.

When I stage the TC72/77 based on Android 8.1 I get no error, just on Android 10 I face this issue.

With "DO" you mean work managed enrollment didn't you? So this is the Agent package I use also.
"DA" is android legacy ?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Darryn Campbell
If this is a fresh out of box

If this is a fresh out of box device then it sounds like this may be a different issue. 

Yes, "DO" and "DA" was Device Owner and Device Administrator - the scenario I was referring to was when a device is upgraded from DA mode to DO mode in the field it requires some special steps.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments