TC20/RFD2000 - charging message despite device not charging - help

Hello all,

I have developed a scanner app for our customer a while back, it runs on the TC20/RFD2000 on Android 7.1 and has thus far functioned without any problems whatsoever for almost 2 years.

Last week, the customer opened a ticket to me. After charging in the cradle, they tried using the scanner as normal, but were unable to, getting the error message "charging in progress-Command not allowed" whenever they tried scanning - even though the device was very obviously NOT charging. What we tried so far:
- Reboot (no change)
- Disconnect and reconnect TC20 from RFD2000 (no change)
- Charging again until full (no change)
- trying the first two after this full recharge (no change)

Now, I know this message isn't related to my app but rather part of the API or system itself. It seems to me that for some reason, some flag either got stuck or keeps being set incorrectly, but since I have no access to that code that doesn't help me.
I think it could also be some kind of hardware issue, but since the devices are out of warranty I'm out of luck if that is the case.

I have already contacted support but they were unable to help me.

Do any of you have any idea what could be happening there and how I can fix it?

Regards

Ian Hatton
Sounds like a hardware issue

Sounds like a hardware issue to me - you could confirm that by installing the 123RFID Mobile demo app to confirm that it is not working with a different app

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Sean Kennedy
TC20 RFD2000 - charging message despite device not charging help

The RFD2000 RFID SLED is not charged from the USB-C port on the TC20 that connects to it.
The CRD1S-RFD2000 - single slot cradle is designed to Charge the RFD2000 RFID sled, as well as the TC20.
As does the 5-slot cradle.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments