Enterprise Browser Cut Off in Landscape Mode

Hello,

I've run into an issue with Enterprise Browser where the viewport is being cut-off when in landscape mode. I've tried every viewport setting in the metatag of index.html and also tried adjusting the settings in config.xml in various ways. No matter what, portrait mode scales perfect but landscape mode cuts off. It's almost as if it can't account for the Android system bar or thinks the screen is wider than it is.

This is on a Zebra TC520k mobile device running EnterpriseBrowser_v3.0.0.1.

I've attached pictures as reference. Does anyone have any advice for fixing this?

Darryn Campbell
I know the docs at https:/

I know the docs at https://techdocs.zebra.com/enterprise-browser/3-0/guide/configreference/#viewport say the 'recommended' setting is to enable the ViewPort config.xml settings but I would suggest you disable those for now (by setting UseWideViewPort to 0).  That should use the values of viewport you specify in your HTML / CSS.  The screen size of the TC52 is 1280x720 so the first thing I would suggest is to ensure the page renders well outside of EB (either in Chrome desktop or Chrome on the device).  Using device-mode (https://developers.google.com/web/tools/chrome-devtools/device-mode) or chrome://inspect respectively.  

Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


David Wilson
Issue still persisting

Hi Darryn --

Thank you for the suggestions.

I've tried doing that with the exact dimensions, and myriad other combinations. The site renders absolutely perfect in Chrome (Android mobile and desktop). However, no matter if set the viewport via meta tag in the HTML or the ViewPort Config.xml tags, the result is the same -- the page cuts off in Enterprise Browser when in landscape orientation. The amount cut-off seems to be exactly equal to the width of the Android button controls at the bottom of the screen, so it almost seems like a bug in EB.

I have a workaround for now which renders the root div at 95% width when in landscape orientation and on a Zebra mobile device, but it obviously is less than ideal.

Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Darryn Campbell
Thanks David, I'll let the EB

Thanks David, I'll let the EB team know so they can fix it.

Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


David Wilson
Thank you

Thank you! Please let me know if you need further details or documentation. Our team working on this would be happy to assist.

Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Joydeep Chakraborty
Hi David,

Hi David,
Can you please share the config.xml and HTML page source you are using, so that we can reproduce the same?
Regards,
Joydeep

Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


David Wilson
Example files

Hi Joydeep,

I have added an additional attachment to the top post in this thread. The file is named examples.zip and it contains both the config.XML and the HTML page source.

Please note, I have tried the config file in a bunch of different configurations and I have also tried the index.html file viewport tags in many forms. These are just the current form, in which I am still seeing the issue with EB being cut off on a TC-520k device when in landscape mode. Additionally, this would be our preferred viewport mode in the config.xml, should we be able to use it.

Let me know if you have any further questions. Thanks!

Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Log in to post comments