your binary is not optimized for iphone 5

Hi,

I am trying to load a new application binary which I created with RhoHub into iTunes Connect via the Application Loader and I am getting an error that my binary is not optimized for the iphone 5. This is a new error which I havent seen before. It appears to be related to a splash image that is needed but I have tried everything I can think of with no luck.

What do I need to do to fix this error (where should I place the image, what should it be called, etc.)

git repo: git@git.rhohub.com:frankbohac/Spray_calculators_Dev.git

Thanks

Fernando Coelho...
Frank, If I'm not mistaken

Frank,

If I'm not mistaken the rhohub not of support for IOS7 maybe that's your problem.

What you can try is to manually generate the Rhostudio and try to open it in Xcode.

About the pictures, were added in IOS 7 new images that are now mandatory. I advise you to look at Apple's documentation.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Maxim Zverev
RhoHub builds are using SDK 7

RhoHub builds are using SDK 7.1 now.

Max.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Frank Bohac
Im pretty sure that my

Im pretty sure that my problem is related to a splash screen image that is now required by ios5, but I cant figure out what to name it or where to place it or if there is a specification I am missing for it in a configuration file somewhere.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Jon Tara
Do you have a loading-568h@2x

Do you have a loading-568h@2x.png?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Frank Bohac
Hi,I had it called 'default

Hi,

I had it called 'default-568h@2x.png'. I renamed it as you suggested and everything is working now. Thanks for the help.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Jon Tara
Lacking 64-bit binary?However

Lacking 64-bit binary?

However, only iPhone 5S has a 64-bit processor. (Not 5G).

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments