MC35 Fails to answer phone calls, does not ring,goes to Voice mail


Audience

1) 09:00/02-24-2009 2) 4 hour 3) MC35 4) WM6.0 5) 1828167 TA from APAC reports the following issue : "I have an MC35 with the latest WM6.0 firmware (L12a).The memory is 128/128.We have even had the mother board upgraded to the latest model. However we are still seeing the following issue. Occassionally when someone is call the Mc35 it will not ring , but will go straight to voice mail. The other issue is that it will ring, but when you hit answer the unit will freeze and you will not be connected to the call which will then drop through to voice mail again." I have attached the RILlog and the Symscript CSV to this post. Any assistance would be appreciated.

Submitted by NPK468 on May 04, 2019 Permalink

Thanks for the reply, Herbert! Soaccording to the RIL log the ring should have been audible...and doesit show whether call was answered or went to Voice Mail?Could this also be a problem on the carrier side? Too many calls being handled by one tower?Here is response from Daniel after I reported your findings.Howard,This unit was flashed with the latest firmware and just the rildrvlog and symscript were loaded as I wanted to test just the phone functionality.Its strange that it showed that the call was picked up when it actually went to voice mail.Are you seeing dll crunch with just the Os running on wm6 units?Note: 2 separate customers and I are seeing this issue.On another note, can we extend the time before a call drops to voice mail? 

Submitted by XBR786 on May 04, 2019 Permalink

At the moment I don’t have a clue what is causing this the rillog is not showing a call going to VM as this is handled by the Network and not on the MUT.

Can you do tests without rillogging enabled ?

And also make some outgoing calls from MC35 and switch from Handset to Speaker mode and Mute the call See if that works OK all the time.

Also you can change the VoiceMail timeout settings

Under Start Settings Personal Phone then select Services and then Call Forwarding and select Get Settings

There should be your VM box number and the time out it Forwards.

Submitted by XBR786 on May 04, 2019 Permalink

Howard,  looking at the rillog i dont see any anomalies. Some remarks 1 rillogging is slowing down mc35 performance 2 there is no GPRS connection active 3 at   214911ms i see incoming call and it is answered on device and audio is activated. all seem to be ok on device and phone application. We know from some cases that WM6 mc35 can also be suffering from dll crunch so that is one route to investigate also what processes are running on this device ?

Submitted by NPK468 on May 04, 2019 Permalink

Thanks for the reply, Herbert!  So according to the RIL log the ring should have been audible...and does it show whether call was answered or went to Voice Mail? Could this also be a problem on the carrier side? Too many calls being handled by one tower?

Submitted by NBX846 on May 04, 2019 Permalink

As I've mentioned before in this forum, the MC35 is NOT handled by ECRT.  I recommend that you send the question to Tom Cassar who can forward to Wistron.