WebPage Rendering ES400 - QVGA vs VGA

I have seen a few posts asking for a Applet to allow someone to switch a MC65 or ES400 from QVGA to VGA, but it seems this is not something we can do.

My customer is going to pilot with a MC65, ES400 and CN50 and are accessing a legacy WebServer. You know whats comming next. The CN50 displays the page just fine, being it is VGA. The ES400 and MC65 display the page in the top right corner and it also comes along with the zoom bar.

My questions are:

1: Are there any registry setting they can do, not chnaging the screen resolution, but changing how IE renders the web page?
2: Is there some kind of tag the IE6 on a 6.5.3 device sends to the web server, that would make the web server send back a page it could render full screen?

Or, how has anyone addressed this successfully?

We have tried the desktop and mobile Views, but no luck.

Any help is appreciated.

Thank you.
Anonymous (not verified)
Marc,  You can nornally fix

Marc,

 You can nornally fix this type of rendering issue by switching IE back to WM6.1 compatibility mode using the attached registry key .

Best Regards,
Ian Hatton
Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Anonymous (not verified)
Marc,  You can nornally fix

Marc,

 You can nornally fix this type of rendering issue by switching IE back to WM6.1 compatibility mode using the  registry key below.

[HKEY_LOCAL_MACHINE\Security\Internet Explorer]
"MSHTML"=dword:00000000

Best Regards,
Ian Hatton
Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Marc Fluhrer
Ian, thanks for the registry

Ian, thanks for the registry setting, it worked how I thought it would, but the customer is looking for the best of both worlds.

They liked how the page would appear full screen, but they miss the zoom bar.

I am assuming this needs to be web page development on their side to make the page come in full screen native to the 6.5.3 OS. 

Is this effort just designing the web page to exactly fit the screen of the device, or is there some tag they would put in the HTML code that would tell the Web Server what kind of browser is trying to access it, then the browser in return knows what size web page to send back to the MC65.

I am also assuming, if the web server sends back the page in the right size, the zoom bar does not appear automatically.

Is this on the correct thought process?
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


William Perryman
I ran into this issue also

I ran into this issue also yesterday. Customer webpage displays properly on MC3090 CE but not on MC9590 WM6.5.3. And if you cllick to zoom then the field pointers to move cursor after scanning stop working also..
Are their any new developments with IE that fix this issue yet? will this reg key work on the MC959x also?
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


William Perryman
Also tested OPera Browser and

Also tested OPera Browser and this resolved the issue so that is something to try. its free.
www.opera.com
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Roman Woloszczuk
You could try adding the

You could try adding the following meta tag to each page...

<meta name="viewport" content="width=240, height=320, user-scalable=no,
initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0" />

Cut and paste into the <head> section of each page.
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Marcus Kurath
Bill You might be able to

Bill

You might be able to address this by setting the zoom on the screen. Ken C gave me this cab file..You might need to adjust the preferred reading zoom value ....

Put all of the files in the attached ZIP file in \Application and do a Clean Boot.  If you don’t want to Clean Boot, then after putting the files in \Application, copy IEZoomLevel.LNK to \Windows\Startup and then do a warm boot.  Every time the device reboots, it should re-run the REG file

Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Afshin Mansoorieh
is it possible to disable the

is it possible to disable the zoom button from appearing on the screen?

thanks,
afshin
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Marcus Kurath
If you can adjust the screen

If you can adjust the screen properly with the zoom key, it is possible to use the registry to change the default zoom setting
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
This reg setting should make

This reg setting should make the screen render like the older versions of Pocket IE.  Does not necessarily change the size, but does remove the zoom bar, etc.

[HKEY_LOCAL_MACHINE\Security\Internet Explorer]
"MSHTML"=dword:00000000
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
Sorry,  looks like someone

Sorry,  looks like someone already gave you that one I just posted.  But here's another possibility. If you use RhoElements, you can add the zoom meta tag to the config.xml file like below.  The default meta tag section will already be there, just add the zoom line between them.

     <DefaultMetaTags>
<MetaTag VALUE="zoom~page:2.0;" />
      </DefaultMetaTags>


 


Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Jun-Hua Liu
Hi Marcus, Could you share

Hi Marcus,

Could you share the password of IEZOOM.zip? I also encountered a similar issue.

Thank you!
Junhua
Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments