MC75A HF (RFID) - Cannot run HF RFID demo app

Device - MC75A6-P3CSWRRHF3R
S#: 11112522503253
Originally loaded with French OS 
SNCF sticker on back of device

Upon receipt of unit (originally French), I was able to successfuly load a CAB file ("MC75ARFID.CAB", which came from "") which creates a sample app ("MC75RFID.exe").  I would then run "MC75RFID.exe" on device without error.

However, I decided to flash the device with an English version of OS (see file names below*) and install CAB file again (copy "MC75ARFID.CAB" to device, double tap CAB file on device).  The cab file successfully installed, however, when I go to run the "MC75RFID.exe" app, I get an error.

Error says: "The file 'MC75RFID' cannot be opened.  Either it is not signed with a trusted certificate, or one of its components cannot be found.  If the problem persists, try reinstalling or restoring this file.

OSUpdate file names I tried loading...
* "" and ""
* ""

I also tried reloading the French OS ("") and I still get same error.

Can anyone point out what I may be doing wrong?  I need to get the sample application up and running.