8 Replies Latest reply on Jul 24, 2014 8:40 AM by Nicolas Etienne

    SB1 severe crash

    Nicolas Etienne

      My SB1 (which is a SB1 AI - Audio integrated) was displaying the lockscreen with issue in the display (line of the middle where "offset".

       

      I decided to re-install the os 36.

       

      I did it.. and during the install, an exception occured saying install didn't complete.

       

      At the end, the SB1 reboot and now is stuck in the Windows CE classic desktop environment ...

       

      Yes, I can see the Start menu (with suspend), and so on

       

      But, how do I get out and reset this bloody machine ?

       

      I've tried Home/scan ==> Nothing happened

       

      So, do I have another solution than sending it back to where I bought it ?

       

      Thanks for any replies

        • Re: SB1 severe crash
          Daniel Silva

          If you can get to the CE Start button, you could try doing the OS update again.  Start/Programs/Rapid Deployment client should get you to the point where you can scan a barcode to do the update.  The Home/Scan should still work to boot though, and you won't see anything happen on the screen.  You have to hold Home/Scan for 10 seconds or so until you see the scanner flash.

          • Re: SB1 severe crash
            Nicolas Etienne

            well the scanner is disabled. I've tried Rapid deployement but scanner being off, can't do anything.

             

            I've tried 10 seconds home/scan, it just reboot the SB1 and go back to windows CE desktop

             

            Can't connect to usb because it is the SB1 New generation (with audio) and I don't have the usb kit yet !

             

            Look like I'm stuck, no ?

              • Re: SB1 severe crash
                Daniel Silva

                So when you start the rapid deployment client, what do you see?  Do you get the "Waiting" screen, or do you see some error? 

                 

                The scanner was working when you tried the upgrade the first time, right?  If it was working then, but not now, it sounds like maybe the OS update failed at a critical point and maybe the scan drivers got messed up somehow.

                 

                If you are using RDT Solo, and you can get the device on the wireless network, you may be able to do ON-DEMAND staging.  Check the help for RDT Solo to see how to use that.  To try to get the device on wireless, you could do Start/Programs/Fusion/Wireless Launch/Manage Profiles  or Find Wlans

              • Re: SB1 severe crash
                Nicolas Etienne

                I've got the waiting screen but the scanner is off

                 

                Yep, during the update, an exception occured saying ... 1BCN6.exe (or something like that) crashed...

                 

                could you give more explanation about the process with RDT solo ? (I have the network)

                 

                Thanks

                • Re: SB1 severe crash
                  Nicolas Etienne

                  OK Daniel, I did follow your advices and now, RhoElementBrowser is back on line...

                   

                  Let me explain why I tried the OS Update.

                   

                  I've done a package (APF file) with files I want to deploy on the SB1.

                   

                  For 3 SB1, the deployment worked fine.. but for only 1 SB1 (the one I'm struggling with), when I try to start a simple application html, the SB1 says : ""system Message, Application is busy or not responding"...

                   

                  I used the same APF for each SB1... all worked fine but this one... what could it be ?

                   

                  the application is only a html file with a div.. no link with asl.css nor asl.js...

                   

                  Looks like if for this SB1, the userdrive was not a good place to place application.

                   

                  Any ideas about what I could do ?

                   

                  I added a sample screenshot of the lockscreen... (as you can see, there is a "display" bug (because the letter should be a WIIO perfect as it is on other SB1).

                   

                  bad.jpggood.jpg

                    • Re: SB1 severe crash
                      Daniel Silva

                      I have not seen that display bug before, not sure what to say about that, but it sounds like this one unit is behaving differently from the others.  Are they all running the same version of the OS?  In advanced settings/Software version, do they all look the same?  Do they all have the same files in \Userdrive?  The Application busy message usually means that either it can't get to some file it is trying to load or that asl.js is not loaded.  If I am understanding you correctly, it sounds like you are not linking asl.js at all, so I would think that is the problem, but I don't know why you are not seeing this error on the other devices.  You can add this reference to your html so that it will link the built in copy of asl.js.

                       

                      <script type="text/javascript" src="http://127.0.0.1:83/Application/www/sapp/src/asl.js"></script>

                       

                      If your apps.json file refers to your html file directly in the file system, try using this same syntax in that file as well, so that it will use the internal webserver on the device at port 83.

                       

                      Something like the below..

                      {

                        "name": "PriceCheck",

                        "url": "http://127.0.0.1:83/UserDrive/apps/test.html",

                        "icon" : "http://127.0.0.1:83/UserDrive/config/logo.png",

                        "canOverwriteBadge": true

                      }

                    • Re: SB1 severe crash
                      Nicolas Etienne

                      Well, i've changed my apps.json and change the url for my application but it's still the same result (application is busy or not responding)...

                       

                       

                       

                      I think it's time to end the research and send back the device to support

                       

                      Thanks for your help Daniel