3 Replies Latest reply on Oct 28, 2014 8:50 AM by Tuomas Määttä

    RhoMobile 4.0 stops working after being not used

    Tuomas Määttä

      We are using RhoElements as a web browser in MC45. We have faced a problem with RE that causes the web application to hang when RE has been running on a device for a while (maybe for hours, over night) but it has not been used. As soon as the RE has started, users are promted to log in using their username and password. Everything works fine if user logs in right after RE has started. But if the login screen has been on the device (for example over night), login seems to be succesfull but user ends up with empty screen instead of the normal menu. This means that RE is causing this for some reason.

       

      I am not a software developer so I don't know how the web application is designed. I have gone through the logs that I can find from the device and I have found something strange that I don't understand.

       

      I 10/20/2014 10:20:24:769 2bbabf9e      MainWindow| ACTIVATE: 0
      I 10/20/2014 10:20:24:782 2bbabf9e       RhodesApp| callAppActiveCallback
      I 10/20/2014 10:20:24:793 2bbabf9e    AppCallbacks| addCommand: APP-DEACTIVATED
      I 10/20/2014 10:20:24:808 2bbabf9e Core::CSync::Run| Running Event:
      I 10/20/2014 10:20:24:817 2bbabf9e Core::CSync::Run| Posting Message for:
      I 10/20/2014 10:20:24:837 89d29826    AppCallbacks| process command: APP-DEACTIVATED
      I 10/20/2014 10:20:24:847 89d29826    AppCallbacks| ThreadQueue blocked for 4294967295 seconds...

       

      During this the web application has hanged and user is forced to reboot the deivece. Rest of the log is attached and this part can be found from page line 6041.

       

      What does 'MainWindow| ACTIVATE: 0', 'APP-DEACTIVATED' and 'AppCallbacks| ThreadQueue blocked for 4294967295 seconds...' mean?

        • Re: RhoMobile 4.0 stops working after being not used
          Kutir Mobility

          This issue needs assistance from Motorola folks.

          Lets wait to hear from them.

           

           

          Thank you.

          Kutir Mobility

          • Re: RhoMobile 4.0 stops working after being not used
            Daniel Silva

            Looking at the log, it looks to me like the lines you are looking at were the app exiting (maybe because it detects that the device is about to boot).  You can see it start back up again at 10:27.  I don't see it trying to navigate anywhere before 10:27

             

            Can you try a controlled test, like keep track of when the app first starts up and shows the login page, and when the user tried to login and get the logs from that period so we can see what happened at those times?

             

            One thought comes to mind for me, I'm wondering if the webserver is timing out the request and maybe trying to show a popup on the  device (we do not support popups).  Can you leave a PC on that same login page overnight and see what happens when you try to login in the morning?

            1 of 1 people found this helpful
              • Re: RhoMobile 4.0 stops working after being not used
                Tuomas Määttä

                Thanks for your response @Dan Silva.

                 

                It does not take 7 minutes to boot, so I think that those lines have nothing to do with device about to reboot. 10/20/2014 10:20:24:769 is the time when user has tried to log in to the application that has been running over night. After this user is shown an empty screen and after a while user decided to reboot the device.

                 

                RhoElements is launched by AppCenter automatically (at 10/20/2014 10:27:21:431) after reboot.