Error - Please install NETCFv35.Messages.EN.CAB on MC9090

We have a third party application on some MC9090's running CE6.x that generates an error message.  Unfortunately the error message does not provide much detail and instead says "An error message is available for this and is not currently installed on this device.  Please install NETCFv35.Messages.EN.cab".  Can someone please explain where we get this CAB file from and what impact it will have on the MC9090 performance.