SAP on Enterprise Browser

Hi All,

 

I am trying to use SAP on Enterprise browser.

SAP ITS mobile has been configured has been configured and we are able to launch SAP and login on Internet Explorer on OS windows CE.


We have been able to launch the SAP application on the Enterprise Browser but the Login Fields are greyed-out and there is an error message.

 

Error message: You are calling this website with a browser that is not supported.

Device: MC9190

OS: Windows Mobile

 

 

The application works ok on a device with the following:

Device: MC9200

OS: Windows 

Browser: Internet Explorer


Has anyone faced this issue where SAP Login fields are greyed-out and login is not possible on a scanner?


Thanks,

Kam 

Peter Arcuri
Kam, I see form your post

Kam, I see form your post that the MC9190 is Windows Mobile while MC92N0 is Windows CE. Please note that Enterprise Browser has a distinct version for each type of Windows. Based on the error you highlighted, it may seem as you're using the WinCE version of EB on the Windows Mobile device. 

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
A few other thoughts for you


A few other thoughts for you.

You should look through this if you haven't seen it.

Enterprise Browser SAP config guide

If you are not already selecting the IE engine in Enterprise Browser,  you should try that.  It is a setting in config.xml.

The back end is most likely using the UserAgent string to decide what kind of browser it thinks you are using.  This can be adjusted in the config.xml if you are using the Webkit engine.  Sometimes you can tweak that a little to get past these kind of issues, but it doesn't always help.  For instance, if you make it look like you are running IE and you are not, the back end might serve some things that only IE will be able to run/show properly.

Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Kamogelo Rannobe
Hi Da Silva,Thanks for your

Hi Da Silva,

Thanks for your update. I have tweaked the Config.xml file but without success.

We have installed the Enterprise Browser (webkit), I modified the Engine to "Webkit" and got same error.

I also edited the UserAgent, had no success there as well.

Next steps will be to install Enterprise Browser (IE version) as suggested by Joydeep to see how that goes.

Thanks,

Kam

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Joydeep Chakraborty
Hi Kam, It seems the SAP

Hi Kam,

It seems the SAP server is trying to find out from which Browser the request is coming from and based on that they are not allowing to proceed? This will be a server side configuration or script which is applying the filter..

1.Can you please share the Login page script from SAP server?

2.I think you have used Enterprise browser for Webkit cab file on MC9190 Windows mobile devices. Can you please try the IE version of the Enterprisebrowser cab and let me know the result? I think that may work fine.

Regards,

Joydeep

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Kamogelo Rannobe
Hi Joydeep,Thanks for your

Hi Joydeep,

Thanks for your update. I am in the process of installing Enterprise Browser (IE version), you are right; we had installed the webkit version. Will give you an update once that I have tested the new install.

Thanks,

Kam

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Kamogelo Rannobe
Hi Joydeep,I installed the

Hi Joydeep,

I installed the Enterprise Browser (IE version), although I do not have the error anymore, I'm now encountering a rendering and screen-size issue.

On the SAP Login screen, the screen is expanded as if it was made for a PC desktop. On the rendering, the text boxes are there but the text which usually precedes the text box appears to be hidden or under the text box.

This is the case for the following text boxes:

Client  (I can only see C)

User (I can only see U)

Logon Language (I can only see L)

Thanks,

Kamogelo

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Joydeep Chakraborty
Please share the HTML content

Please share the HTML content of the page where you are seeing this behavior. It will not possible to comment on the same without seeing the HTML code.

Regards,

Joydeep

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Kamogelo Rannobe
Hi All,My issue was resolved

Hi All,

My issue was resolved by installing Enterprise Browse 1.4.0.0 (WEBKIT). Now SAP is launching and when clicking login you get the required Login Prompt pop-up.

Now SAP fields are not appearing correctly on the screen. Looks like sap page is only using a quarter of the scanner screen. Do yo know where to alter this settings? I have already tried

increasing the following setting from Config.xml and did not get desired result: <pagezoom value="1"/>. Screenshots of current appearance. 

Capture.PNG

Thanks,

Kam

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Kamogelo Rannobe
Solution: To get SAP screen

Solution: To get SAP screen to occupy whole screen. Set resolution at SAP HTML code to be same as Scanner default resolution.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments