Can Enterprise Browser access pages rendered by a PHP MVC?

I have developed my company's Intranet using Laravel, a PHP MVC, I would imagine that the pages should render because from the server to the gun it is only a HTML page. I followed the instructions to setup the start page on the device. Can someone help me or give me advice?

Anonymous (not verified)
We would need a little more

We would need a little more to go on.

Which device/os are you using? 

Is it http or https?   If https,  make sure the date/time is set right on the device.

What do you see on the screen, is it blank?

Can you get to the page with the regular browser on the device?

Are you sure the device is on a wireless network that can get to the webserver?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Michael Deck
I am using MC92N0 with

I am using MC92N0 with Windows Mobile 6.5 with Enterprise Browser. I have two internal servers available to be used, one uses http and the other use https. Neither one works. When it loads it gives me "unable to find page" and a button that says back. I am trying to test the demo version before I get my company to purchase the license for the software. I can open the page using the regular Internet explorer on the device. It has to be on the same network as webserver in order to open the page at all. The server is not publicly accessible at the moment.

If needed I can provide my config.xml

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Joydeep Chakraborty
Hi Michael,1.WHich version of

Hi Michael,

1.WHich version of Enterprise Browser are you using?

2.ARe you using webkit or IE engine to render the page?

3.Is the page accessible in Internet explorer in the device?

4.ARe your devices/date time settigs and time zone correct?

5.ARe you behind any proxy? If so you need to set HTTP_Proxy and HTTPS_Proxy accordingly?

6.Is there any certificate needed to access your server url?

Regards,

Joydeep

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Michael Deck
1. I am using version 1.2.9.0

1. I am using version 1.2.9.0 Demo

2. I am using webkit

3. Yes I can access it through internet explorer.

4. Yes it is set correctly.

5. I don't think that I need any proxy. The only thing is one version uses a .local url mapped in the company's DNS Server.

6. One server requires a HTTPS connection but the other one does not and neither work.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Joydeep Chakraborty
Thanks Michael,Does it work

Thanks Michael,

Does it work if you provide direct IP as startpage  instead of setting Hostname, which needs to go through DNS server?

Regards,

Joydeep

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Michael Deck
It works in regular internet

It works in regular internet explorer but not in the enterprise browser.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Joydeep Chakraborty
H Michael,Can you please

H Michael,

Can you please confirm the same. I am little confused.

1.when you provide hostname instead of IP address,this does not work in EB but works on IE in device.

2.When you provided IPAddress as startpage then it works in EB as well?

Regards,

Joydeep

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Michael Deck
Config.xml file attached


Config.xml file attached because it won't let me paste it.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
Try adding a slash to the end

Try adding a slash to the end of the start page  http://ip_to_server/scanner/

If that doesn't help,  I think there should be a log file in your Enterprise Browser install folder on the device.  That might have some clues.

You could also try the IE version of Enterprise Browser to see if that works (at least for a test). 

Also, be aware that if the device is connected to your PC with Activesync,  that can have an effect on how the connection works (it can try to connect through that connection) so make sure you are testing both the internal browser and Enterprise Browser the same way (preferably not connected to USB).

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Michael Deck
Here is the error that is

Here is the error that is given in the log file:

W 11/13/2015 15:49:31:221 d6d98752 Scanner::CScannerModule::MetaProc| The Scanner API has been deprecated in 4.0, please transition your applications to use the Barcode API for future releases

W 11/13/2015 15:49:31:232 d6d98752 Scanner::CScannerModule::MetaProc| The Scanner API has been deprecated in 4.0, please transition your applications to use the Barcode API for future releases

W 11/13/2015 15:49:31:243 d6d98752 Scanner::CScannerModule::MetaProc| The Scanner API has been deprecated in 4.0, please transition your applications to use the Barcode API for future releases

W 11/13/2015 15:49:31:250 d6d98752 Scanner::CScannerModule::MetaProc| The Scanner API has been deprecated in 4.0, please transition your applications to use the Barcode API for future releases

W 11/13/2015 15:49:32:186 d6d98752 Scanner::CScannerModule::MetaProc| The Scanner API has been deprecated in 4.0, please transition your applications to use the Barcode API for future releases

E 11/13/2015 15:49:40:640 f1f510ce              System| invalid http proxy url

E 11/13/2015 15:49:41:437 b1c33fb2              System| invalid http proxy url

E 11/13/2015 15:50:10:203 f43aca46              System| invalid http proxy url

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments