How to disable input field double-click zoom in Internet Explorer on MC92N0 or CE7 ?

There is "solution" on Zebra support portal - How to disable when tapping on an input field on a Windows CE 7 device, the browser zooms in on the field?

It has just one TINY issue - if you set:

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Gesture]
"GestureCapabilities"=dword:000002C6

You will disable not only double-click but any click in Internet Explorer so you won't be able to use touch panel at all.

Is there any other solution for this?

 

P.S: IE "Kiosk" mode on CE7 (device must patched or latest OS) can be user overridden with F11 so the key must be disabled (kbtool)

 

UPDATE:

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Gesture]
"GestureCapabilities"=dword:00000710

This works correctly. (2C6 is hex value for decimal 710, but .reg file must contain 710 hex to set 1808 decimal value in device registry)

 

UPDATE2:

 

Just for clarification second key from the solution is working correctly and both of them must be used

 

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\EditActivation]
"EnableEditActivation"=dword:00000000

for more info - https://support.microsoft.com/ja-jp/kb/2887667https://support.microsoft.com/ja-jp/kb/2887667

or https://community.ivanti.com/docs/DOC-31976

 

Zprávu upravil(a): Michal Keracik