How to disable a Touch screen on MC9200 CE7 through Reg key

Hi All,

 

Does anyone know the Reg key to disable a Touch screen on MC9200 CE7?

 

Regards,

 

Mazhar

Christopher Sather
I use Symscript.Command;***

I use Symscript.

Command

;*** Disable the touch screen.  Comment out to keep it enabled.

DevicePower TCH1: 4 1

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Mazhar Iqbal
Hi Chris,Do you have a script

Hi Chris,

Do you have a script which you can send it to me.

Regards,

Mazhar

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
Try below.  Sets initial

Try below.  Sets initial state to off and puts in some dummy calibration data so you don't get the calibration screen on cold boot.

[HKEY_LOCAL_MACHINE\Drivers\BuiltIn\Touch]

"InitialState"=dword:00000004

[HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\TOUCH]

  "CalibrationData"="1990,2070 3012,3137 2960,1013 930,981 929,3174 "

[HKEY_CURRENT_USER\Software\Symbol\Startup]

  "SkipCalibrate"=dword:00000001

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
While this works after a boot

While this works after a boot,  I just noticed that if you suspend/resume,  touch comes back. 

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Mazhar Iqbal
I tried this Reg Key but it

I tried this Reg Key but it didn't work. I had the same result as yours.

[HKEY_LOCAL_MACHINE\Drivers\BuiltIn\Touch]

"InitialState"=dword:00000004

We have to find another way to disable the touch screen.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
Try this.  I looked at a

Try this.  I looked at a WT41N0 (non touch) and one of the things I found is the second setting here.  Set the DLL to blank.  Seems to work OK even after suspend,  but I would test further.

[HKEY_LOCAL_MACHINE\Drivers\BuiltIn\Touch]

"InitialState"=dword:00000004

[HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\TOUCH]

"DriverName"=" "

[HKEY_LOCAL_MACHINE\HARDWARE\DEVICEMAP\TOUCH]

  "CalibrationData"="1990,2070 3012,3137 2960,1013 930,981 929,3174 "

[HKEY_CURRENT_USER\Software\Symbol\Startup]

  "SkipCalibrate"=dword:00000001

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Herbert De Jong
it should be fixed with this

it should be fixed with this CFE

MC92 CE 7.0 - BSP v02.46.02 - HotFix CFE v02.06.00 PackageLocked

MC92 CE 7.0 - BSP v02.46.02 - HotFix CFE v02.06.00 Package

or with

OEM 03.54.02

Update LoaderImage v03.54.02 and PSDK v03.00.00 for MC92N0 CE 7Locked

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments