Odd spacing in multi-line format fields

I am working on a Windows tablet application that generates ZPL label formats from a database and send them to a ZQ520 printer over a Generic/Text printer driver. Generating the ZPL format and sending it to the printer works like a charm. I am running into an issue where the multiline text in either Table Block, Field Blocks or simply Field Data tags has extraneous spaces between several words. Even after changing the font for the fields, I still get the same spacing between the same words. I have examined the text of the ZPL file in a hexadecimal editor and there are no extraneous characters in the fields, the placement seems to be random in that there is no common combination of characters triggering the extraneous spaces.

 

One of the attempts I have made to try to narrow the problem down is:

 

^XA

^LL800

^LH15,15

^FO15,0

^A022,22

^TBN,752,250^FDLorem ipsum dolor sit amet, consectetur adipiscing elit. Proin porttitor porta urna sed pharetra. Quisque at malesuada dolor. Cras mollis justo neque, quis commodo arcu condimentum molestie. Ut elit justo, tempus vitae nulla sed, rutrum fringilla dui. Proin scelerisque nisi pretium arcu tristique, eu mollis ante fermentum. Ut eu imperdiet sem. Proin ultricies sit amet sem sodales fermentum. Morbi vehicula elementum tempor. Suspendisse ut ligula ac nunc aliquam consectetur. Nullam nec scelerisque ante. Nam sodales justo at velit vestibulum, non dignissim risus feugiat. Morbi consectetur sit amet ligula ut dictum. Quisque efficitur, lorem vel ullamcorper blandit, magna nibh sodales metus, non egestas felis erat pretium justo. Aliquam pulvinar ex eget condimentum suscipit. Pellentesque sed ornare nibh. Nunc commodo ullamcorper tincidunt.^FS

^XZ

 

The spaces appear between adipiscing and elit, malesuada and dolor, condimentum and molestie, dui. and Proin and many others. I have also tried using fonts C, D, F and 0 (zero). Additionally, I have also used the ZPL and the CPCL Zebra printer drivers as well as the Seagull Scientific driver with the same results on both a Windows tablet and a Windows PC.

Gregory Pawlik
Hi Russel,What firmware

Hi Russel,

What firmware version is on your ZQ520 printer?

Greg

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Russel Madere
The firmware version is V76

The firmware version is V76.19.15Z. It was updated earlier this month from 13Z on the advice of our vendor.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Gregory Pawlik
Thanks, Russel.I sent the ZPL

Thanks, Russel.

I sent the ZPL you provided to a ZQ520 running the same firmware by copying and pasting it to the command window Zebra Setup Utilities that uses the Zebra Designer driver.

My output looks like this:

IMG_0474.JPG

Doesn't appear that I'm getting any extra spaces.

What does yours look like?

What kind of a file is your application sending your ZPL in to the driver?

Is it a .txt or .doc?

Greg

Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Russel Madere
Here is what my results look

Here is what my results look like:

20160525_070350.jpg

I'm sending the file as ASCII text with a ZPL extension from Notepad on a Windows 10 tablet, via bluetooth, to a generic Text printer driver. I am also sending the same file from a Windows 8 PC, via USB, to the Zebra CPCL driver. The ZPL version of the driver on the PC will never connect to the USB port. Neither the CPCL, ZPL or Seagull drivers on the tablet will work consistently. However, when they do, I get the same results.

Russel

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Russel Madere
Thinking the issue might have

Thinking the issue might have been a bad setting because I have been tying to make this printer work for quite a while now I executed the following commands:

^XA^JUF^XZ
^XA^JUN^XZ
^XA^JUS^XZ

I then re-enabled Bluetooth and ZPL via a Set/Get/Do script.

After all of this, I still get the same issue with the spacing. Is it possible that the fonts might be corrupt?

Russel

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Gregory Pawlik
Russel,Before you go to print

Russel,

Before you go to print from notepad, got to File->Page Setup.

Set all the margins to 0.

Make sure that the Header and Footer boxes are empty.

notepad.png

Then print through your generic text driver.

Hope this helps.

Greg

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Russel Madere
That worked. Why was I

That worked. Why was I getting this problem when printing from the ZSU? Also, I will be printing this from a web browser eventually, will the same setting work there?

Russel

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Gregory Pawlik
I believe the notepad adds

I believe the notepad adds some extra characters when printing or copying to the clipboard if the margins and header/footer are set.

It should work the same when printing from a web browser.

Greg

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments