Set correct date and time during a deployment

I create with the tool "MSP Package Builder" a deployment package for the Zebra SB1. With the tool "RDT Solo" I deploy the package to the SB1 device. Everything works, but on each deployment the date and time on the device is reset to a default value. Is it possible to set the date/time to a valid value during the deployment (e.g current date/time of the deployment server)?

 

Thanks!

 

Regards

Martin

Anonymous (not verified)
I think you will see the time

I think you will see the time revert to the default every time you reboot.  You can set the device up to pull the time from an ntp server.  I have attached the utilities folder from the SB1 toolbox package.  This has examples showing how to do this. For some reason that package did not make it to the new support site.  I am working on getting that fixed, but the attached zip should give you what you need for now.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
The whole "SB1 Software

The whole "SB1 Software Developer Toolkit" is now up on the support site.  You might want to download that and look through it.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Martin Schagerl
Thanks. I try it

Thanks. I try it:

  • DeviceTimeSync: WORKS
  • SetTimeZone-Setup: Doesn't work - I doesn't receive a error mesage but the timezone is furthermore -8 hours. Is there a way to determine where the error happens?

Thanks!

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
Looks like there is a mistake

Looks like there is a mistake in SetTimeZoneById.cpy.  They have it set to copy files from \application instead of where they should be in \userdrive.

Edit the file to look like this and try again.

\userdrive\SetTimeZoneById.lnk > \Windows\StartUp\SetTimeZoneById.lnk
\userdrive\SetTimeZoneById.exe > \windows\SetTimeZoneById.exe

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Martin Schagerl
Thank you very much. I will

Thank you very much. I will try it in the next days.

On other question: What is the prefered way to handle summer and winter time (daylight saving time)?

Thank you very much for helping!

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
CE should be set up to handle

CE should be set up to handle that by default.  You could test by manually setting the device to about 5 minutes before the time that the change should happen and see if it adjusts itself.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Martin Schagerl
Thank you very much, it works

Thank you very much, it works!

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments