getEMDKManager method - EMDKManager object request fails


Audience

I'm following this tutorial on a TC56DJ device and i'm trying to initialize the scanner. getEMDKManager method always returns "NONE" as statusCode and the app crashes in onOpened (at getInstance).
I've also tried barcodesample1 as is with the same result
 
Here is my code in onCreate,
 
EMDKResults results = EMDKManager.getEMDKManager(getApplicationContext(), this);
 
if (results.statusCode != EMDKResults.STATUS_CODE.SUCCESS) {
 
  System.out.println(""EMDKManager object request failed!"+ results.statusCode);  // Prints NONE
 
}

and here is my onOpened,
 
@Overridepublic void onOpened(EMDKManager emdkManager) {
 
  this.emdkManager = emdkManager;
  emdkManager.getInstance(EMDKManager.FEATURE_TYPE.BARCODE);
 
}

The log.
 
A/art: art/runtime/entrypoints/quick/quick_trampoline_entrypoints.cc:923] Check failed: called != nullptr int java.lang.Enum.ordinal() com.symbol.emdk.EMDKManager$FEATURE_TYPE[] virtual 15
A/art: art/runtime/barrier.cc:90] Check failed: count_ == 0 (count_=-1, 0=0) Attempted to destroy barrier with non zero count
A/art: art/runtime/runtime.cc:366] Runtime aborting --- recursively, so no thread-specific detail!
A/art: art/runtime/runtime.cc:366]
A/libc: Fatal signal 6 (SIGABRT), code -6 in tid 3877 (x.myapplication)

Any hints?

Submitted by Victor Sanchez on May 04, 2019 Permalink

I have the same problem and the sample posted here is not working.
Version of EMDK Service is 6.6.14.914 and BSP is 01-21-04.1-MG-00-UPDATE005 release-keys

What can I do?
Thanks in advance.

Submitted by tasos@mobilefx.com on May 04, 2019 Permalink

Thanks for your responses.Apparently i was using an older sample.I downloaded the one Bill suggested and it runs fine.
Still when i use any of the tree jars from 'Symbol EMDK for Android' (v19, v22, v23) folder i get NONE as status code.I've added the two lines for permissions on my manifest,

  and

Submitted by Anonymous (not verified) on May 04, 2019 Permalink

That sounds very strange, NONE is the default value for the status so it is almost as if EMDK does not exist on that device.  TC56 is obviously the very latest device so EMDK should be pre-installed but you could try updating the device runtime, if you are on Windows it should be on your hard drive at "C:\Program Files (x86)\Symbol EMDK for Android\v6.0\Device Runtime Deployment"

It is not an issue I have seen before but I do not have a TC56 device to try to reproduce.