1 Reply Latest reply on Aug 7, 2017 11:20 PM by Darryn Campbell

    Trouble getting builds to work (nube questions)

    Chris Jennings

      Hi,

       

      I'm new to Android and am having what I think are dependency issues when trying the tutorials.

      I'm targeting the mc9200.

      Android Studio version 2.3.3

       

      Working on Mac OS Sierra (version 10.12.6), so followed this: EMDK For Android Setup on Mac (Android Studio) - Zebra Technologies Techdocs . All seemed to go well.

       

      I worked through this: Data Capture Profile Feature Tutorial - Zebra Technologies Techdocs

      But the build fails with errors like this...

      Error:(3) Error retrieving parent for item: No resource found that matches the given name 'android:TextAppearance.Material.Widget.Button.Borderless.Colored'.

      and...

      Error:Execution failed for task ':app:processDebugResources'.

      > com.android.ide.common.process.ProcessException: Failed to execute aapt

       

      My best nube guess is that there might be a mismatch between the Compile SDK Version and the Build Tools Version in the Project Structure settings. I've tried all sorts of combinations but can't get it to work. (My app's build.gradle is attached)

       

      Any ideas?

      Thanks!

      -Chris