Restart Zebra printer Label not printing UTF-8 font

Hello there,

 

I have a situation when i switch off and start the printer the UTF-8 characters is not being detected by the printer. But then when I send a notepad file via printer setup utilities it prints. Then it prints the text and then everything comes back to normal and then when I send the UTF-8 characters in the Hex format from my application to the Zebra ZT410 printer it is printing again. It will work till I again switch off the printer. What is that I need to do so that the printer does not behave in this way. THe ZPL2 code I send from my application is below. I will appreciate your help!!

Thanks!!

 

^XA

^LH0,0

^FO50,50

^BXN,4,200,26,26

^FD${fnc}^FS

^FO168,45^A@N,25,25,E:OCR003.TTF^FPH\^FH^FDGON:^FS

^FO265,45^A@N,25,25,E:OCR003.TTF^FPH\^FH^FD${PO}^FS

^FO168,75^A@N,25,25,E:OCR003.TTF^FPH\^FH^FDYY:^FS

^FO265,75^A@N,25,25,E:OCR003.TTF^FPH\^FH^FD${uuy}^FS

^FO168,105^A@N,25,25,E:OCR003.TTF^FPH\^FH^FDJJXP:^FS

^FO265,105^A@N,25,25,E:OCR003.TTF^FPH\^FH^FD${jj}^FS

^FO168,135^A@N,25,25,E:OCR003.TTF^FPH\^FH^FDLRR:^FS

^FO265,135^A@N,25,25,E:OCR003.TTF^FPH\^FH^FD${FGT}^FS

^FO50,170^GB730,1,3^FS

^FO50,190,0^A@N,30,30,E:ARI004.TTF^FPH\^FH^FD${BB}^FS

^FO50,220,0^A@N,30,30,E:ARI004.TTF^FPH\^FH^FD${AA}^FS

^FO50,250,0^A@N,30,30,E:ARI004.TTF^FPH\^FH^FD${CCD}^FS

^FO50,410^ARN,10,10^FPH\^FDContains: ${RTYH} ${TTGH} of ${GGG} ${WWW}^FS

^FO50,450^ADN,18,10^FPH\^FH^FDStore below 30_C2_B0C. Protect from Freezing^FS

^FO50,470^ADN,18,10^FPH\^FDDFERF:^FS

^FO50,490^ADN,18,10^FPH\^FDXXXXX^FS

^FO560,190^XGE:FRAGILE.GRF^FS

^FO680,190^XGE:HANDLE.GRF^FS

^FO560,300^XGE:NOSUN.GRF^FS

^FO680,300^XGE:TEMP.GRF^FS

^FO560,410^XGE:NOWATER.GRF^FS

^FO680,410^XGE:UPRIGHT.GRF^FS

^FO50,520^GB730,1,3^FS

^PA1,1,1,1^FS

^FO775,540,1^A@N,35,35,E:RA005.TTF^FPH\^FH^FD${ASD}^FS

^FO775,570,1^A@N,35,35,E:RA005.TTF^FPH\^FH^FD${RFG}^FS

^FO775,600,1^A@N,35,35,E:RA005.TTF^FPH\^FH^FD${TTT}^FS

^FO775,655,1^A@N,30,30,E:RA001.TTF^FPH\^FH^FD_D9_85_D8_AD_D8_AA_D9_88_DB_8C_3A ${GGB}^FS

^FO50,720^XGE:OG.GRF^FS

^FO775,700,1^A@N,25,25,E:RA000.TTF^FPH\^FH^FD_D8_AF_D8_B1_20_D8_AF_D9_DA_AF_D8_B1_D8_A7_D8_AF_20_D9_86_DA_AF_D9_87_D8_AF_D8_A7_D8_B1_DB_8CŒ^FS

^FO775,730,1^A@N,25,25,E:RA000.TTF^FPH\^FH^FD_D9_87_D8_A7_D9_81_D8_B8_D8_AA_20_D9_86_D9_85_D8_A7_DB_8C_DB_8C_D8_AF_2E^FS

^FO775,760,1^A@N,25,25,E:RA000.TTF^FPH\^FH^FD_20_D8_A7_D8_B2_20_DB_8C_D8_AE_20_D8_B2_D8_AF_DA_AF_DB_8C_20_D9_85_D9_

^FS

^XZ

Anonymous (not verified)
For changing the character

For changing the character encoding, it is command ^CI. For example, ^CI28 changes the encoding to UTF-8. In order to persist the change on the printer, we need to use ^JUS command to save the changes into EEPROM on the printer.

You could use Printer Setup Utility to issue the following to set UTF-8 encoding on the printer. The setting will survive the reset.

^XA

^CI28

^JUS

^XZ

Or, in the application, make sure the encoding is correctly set to UTF-8, before we send UTF-8 characters to the printer.

Hope this helps.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Zolf Jafari
Steven, thanks for your

Steven, thanks for your feedback. I tried this but after restart it still does not print the Persian characters. I have to run that cmd which you poseted everytime i restart the printer for my application to be able to print the Persian text. Please see the attachment to get an i idea. I will appreciate any help to resolve the issue!!

label issue.gif

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
It looks like that the CI28

It looks like that the CI28 configuration cannot be persisted over a restart. In this case, we can either add CI28 command in the ZPL statements of each label or have separate ZPL statements for configuring the printer when the application connects to the printer every time, instead of manually running the CI28 command every time.

Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Zolf Jafari
Thanks for your feedback, I

Thanks for your feedback, I will try it!!

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments