bluetooth.le.controller_mode on iMZ

Hi,

I'm trying to check the current status of the Bluetooth Low Energy controller on my iMZ320 but I can't have the reply from the printer.

I tested to send ! U1 getvar "bluetooth"

This is working but there is no line about the bluetooth.le.controller_mode even if I click several time on "Send to printer"

Here is what I get:

bluetooth.

bluetooth.discoverable : on , Choices: on,off

bluetooth.friendly_name : XXXXJ171602491

bluetooth.version : 5.5.2

bluetooth.date : 10/03/2017

bluetooth.local_name : XXXXJ171602491

bluetooth.address : AC:3F:A4:5F:D4:67

bluetooth.bluetooth_pin : *

bluetooth.short_address : AC3FA45FD467

bluetooth.radio_version : 2.1

bluetooth.enable : on , Choices: on,off

bluetooth.connected : no

bluetooth.minimum_security_mode : 1 , Choices: 1,2,3,4

bluetooth.connected_security_mode : nc

bluetooth.bonding : on , Choices: on,off

bluetooth.clear_bonding_cache

bluetooth.enable_reconnect : off , Choices: off,iOS_only

bluetooth.allow_non_display_numeric_comparison : print , Choices: off,print,no print

bluetooth.json_config_channel_enable : on , Choices: on,off

bluetooth.page_scan_window : 60 , Choices: 15,60

I tested the command ! U1 getvar "bluetooth.le.controller_mode" but the printer reply "?"

Could you help me with this issue??

Many thanks

Daniel Quagliana
The iMZ does not support

The iMZ does not support Bluetooth Low Energy, only Bluetooth 2.1. The new ZQ320 does, though.

Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Log in to post comments