Datet/Time TimeZone after coold boot on MC2180

I need to persist Time Zone settings in Date/Time properites after cold boot on MC2180, WCE6.0.

I have put following lines in .reg file

REGEDIT4

[HKEY_LOCAL_MACHINE\Time Zones]

    @="W. Europe Standard Time"

but it looks like, you have to go to this setting and press OK (right button, on top of this screen) in order to "activate" this setting.

Otherwise my clock is +5 hours off.

Problem is that my Setting in TZ is set too GMT+1, Amsterdam, Berlin..., and showing it, but it looks like it's still on different TZ.

Nenad Novosel
I have found the same

I have found the same behavour like described in this article

boot - Motorola MC3190 - Windows CE 6.0 configure device time through registry - Super User .

So it looks it's a rather known problem

My solution is:

DL & install StartUpCt

In Application\StartUpCtl\OnRestore folder find OnRestore.txt file

put Reset line at the end of onRestore.txt

Do cold boot and enjoy.

If there is a simpler solution, pls. share.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


edul billimoria
Hello Nenad,I don't think

Hello Nenad,

I don't think there is another way to get this working.

I have the same problem on MC9190 & MC9090's running CE.

After a cold boot, I have to do a warm boot to allow the time settings to kick in.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments