1 Reply Latest reply on Jul 23, 2018 8:00 PM by Christine Hughes

    Label is not printing the Full length of the label

    Christine Hughes

      7/20/2018

      I am working on code to print to a 105SL+300dpi printer.  I am able to print and the label is mostly correct except that the first inch is not printed. The odd part is that the x,y coordinates for the lines to print fall within that first inch and the printer seems to "know" where to start the line, it just doesn't print the first inch.....   ??? Any help or suggestions would be appreciated!!

       

      Printing on a 4x5 label (see attached image for orientation as it comes off the printer)

      The string of commands I am sending:

       

      ~JA

      ~JO^XA^EG^XZ

      ^XA

      ^PMN^COY,345^MNY^SLT^MTT^MD0

      ^ST datestring,M

       

      ^LH0,0^PR3^JMA

       

      ^FT82,1462^A0B,68,68^FC%^FDDATE=%y/%m/%d^FS

      ^FT180,1462^A0B,68,68^FC%^FDTIME=%H:%M   ^FS

      ^FT278,1462^A0B,68,68^FDHP Prod. No: ABC1234^FS

      ^BY2,3,100^FT464,1462^B3B,N,,N,N^FDABC1234^FS

      ^FT504,1462^A0B,42,42^FD(1P) P/N ABC1234^FS

      ^FT600,1462^A0B,58,58^FDSUPPLIER: XYZ456^FS

      ^FT705,1462^A0B,58,58^FDBox Quantity 3^FS

      ^BY2,3,100^FT891,1462^B3B,N,,N,N^FD3^FS

      ^FT998,1462^A0B,68,68^FDModel NO: D4^FS

      ^FT1080,1462^A0B,68,68^FDDispensehead Cassettes^FS

      ^FT1162,1462^A0B,68,68^FD^FS

      ^BY129,129^FT225,825^BXB,6,200,32,32,1^FDTesting789456;ABC1234;3;180719152702;US^FS

      ^FT75,540^A0B,42,42^FDMC LOT: Testing789456^FS

      ^FT128,540^A0B,42,42^FDABC1234^FS

      ^FT180,540^A0B,42,42^FD3;180719152702;US^FS

      ^FT232,540^A0B,42,42^FD^FS

      ^FT450,540^A0B,58,58^FDMADE IN US^FS

      ^FT502,540^A0B,42,42^FD(Includes foreign content)^FS

      ^BY2,3,100^FT668,540 ^B3B,N,,N,N^FD4LUS^FS

      ^FT720,540^A0B,42,42^FD4LUS^FS

      ^FT975,540^A0B,58,58^FDNon-Sterile ^FS

       

      ^PQ1,0,0,Y^XZ

       

       

       

      I have run this on an online zpl viewer and it looks correct in the app.  http://labelary.com/viewer.html

       

      I'm attaching an image of the label as it was printed from the printer (ATII_MCLabel) and an image of a Label as it should look (MC_Label).

       

      The printer is at a contract manufacturing company in China, so I don't have direct access to the printer.  I will be meeting via online with them on Monday evening (their Tues morning) where I will test out any suggestions.  They did bring a Zebra Rep to their site to verify Printer settings and such.  I have asked that they verify the Max Print Length was set to a value higher than 5 inches, and I was told that it was set to 900mm.

       

      I've played with this line: ^LH0,0^PR3^JMA

      I've tried defining Length and width : ^LL1522,^PW1218 but it did not help.

       

      Thank you in advance for any recommendations or help!!!

       

       

      Added 7/23:

      I called the Zebra Support, and I tried some of his suggestions. Which was to verify the print area in the driver.  I did this on a labeller that is printing correctly.  I changed the driver values to see if I could recreate the issue that I am seeing on the 300dpi printer. Since I am sending string command directly to the printer via Ethernet, the driver settings did not affect my label.

       

      Any other suggestions or ideas would be greatly appreciated.  Thank you!!

       

      Added 7/23:

      I just found a note in the command ^LL: "Values for y depend on the memory size. If the entered value for y exceeds the acceptable limits, the bottom of the label is cut off. The label also shifts down from the top to bottom."

      I found a command ~HI Host Identification that will cause printer to send Info on module, sw vers, d/mm, memory size and options.

      My printer that I am working with and that prints with no issues has a memory size of 10840kb. I will find out this evening the memory size of the 300 dpi printer that is not printing correctly.

      I am now looking for information on what values for y are acceptable for the various memeory choices in printers. Can anyone point me to that information?  Thank you.