Detection of black mark isn't correct on iMZ320


0down votefavorit

I'm using since two years now Zebra printer type imz320 and I have a problem with it. I received my new labels with black marks, between each black mark there is 24cm of height. I setup the printer as "black mark" and sent the ~jc end ~jg commands to calibrate it. Problem is that when I print (always the same image) the label sometimes stops 3 or 4 mm before the black mark so I can't cut the label because there is inside this black mark a "pre-cut", so I have to pull manually the label to see this pre-cut, but after that when I print a second image, the printer is printing the first label and then is feeding a second label...

For information I'm using labels with black mark as well but the length between each black mark is about 17cm and it's working perfectly.

Problem is located at this media sensor I guess which is stopping the label 3mm approx before the cutter.printer issue.JPG

I updated the firmware to the last version of 15-10-2018.

Many thanks for your help!

Enclosed are some pictures.

Anonymous (not verified)
What's the output of the

What's the output of the following SGD command?

! U1 getvar "media"

If we want the perforated line align with the cut, we need to set the printmode to "tear off", i.e.

! U1 setvar "media.printmode" "tear off"

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


F Sissaoui
Hi Steven,Below is the output

Hi Steven,

Below is the output of  ! U1 getvar "media" 

media.

media.status : ok

media.sense_mode : bar , Choices: bar

media.tof : 0 , Choices: -84.0-64.0

media.type : label , Choices: label,journal

media.bar_location : front , Choices: front

media.width_sense.

media.width_sense.enable : off , Choices: off

media.width_sense.in_mm : 72.1

media.width_sense.in_cm : 7.21

media.width_sense.in_dots : 576

media.width_sense.in_inches : 2.837

media.printmode : rewind , Choices: tear off,peel off,rewind,cutter,delayed cut,linerless peel,linerless rewind,linerless tear,applicator,linerless cut,linrless dly cut

media.speed : 3.2 , Choices: 1.0-5.0

media.feed_length : 1861 , Choices: 0-20000

media.feed_skip : 35 , Choices: 0-50

media.draft_mode : off , Choices: on,off

media.part_number : 

I sent the command ! U1 setvar "media.printmode" "tear off"

...and it's working!!!!

Could you explain me what this command do exactly?

Many thanks for your help and your support Steven.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
The ! U1 setvar "media

The ! U1 setvar "media.printmode" "tear off" command sets the printer in "tear off" mode. Here is the explanation for different Print Modes.

Prior to running the above command, your printer was set to "rewind" mode, as shown in the response msg above. The "rewind" mode causes the label to backfeed a little bit.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments