1 Reply Latest reply on Oct 31, 2018 5:50 AM by Christian Stingl

    Black border on PNG

    Christian Stingl

      Hi Zebra,

       

      could you help me with the following ZPLII code?

       

      ^XA

      ~DYR:MILOGO,P,P,429,,89504e470d0a1a0a0000000d49484452000000920000002801000000003d519e300000017449444154789c8d92314e233114863f3b4332058a67454301c247405bd1e19263506cbfdc0027a1e0181cc5236db12517403b48141414465a699de0ccdb620233210dafb23eff7effef67134d9e1a1191782e5d051df9dbb25d9af4be743d238e22401ce868d6c7c7d5b2e491dabd6aa000aa9cd2ef15777f6a732f806e08999883c00329e0416f7a2c1a4eb3c9a306d0f85bec540a2e2fa8fc4de791217d03b849966401ada4b258965641ed6b3ce8d01ea6ae6d7ecfdd7908463cf6facd848e399c0342224000b476b8884e73896e3dfe37eb745711cae51ccbaf7205a0bd025014a85bbe6f66a0819670b6184fa8950794f0b96abd83fa197c9949094bb7ab4b9f59b97b56c55ebf797cc94753e34d38492a141f9b31bf819b3c8b1f782490716e06775bdb2725fb073fda9f55afcb46372fb4f3b2f74887278b26a22612b632375db621f30a648b590b9c675e0759babf59107b5d824278d85bddf9edf95d3c95321bf4730205a75e0f7d1d76340b5747fc07b86ba587d33713170000000049454e44ae426082

      ^FO0,0

      ^XGMILOGO.PNG

      ^FS

      ^XZ

       

      With the ~DY command, a PNG graphic is loaded into the printer RAM. It is correctly displayed in the web interface, see attachment 1.

       

      However, when I insert the graphic into a label with the ^XG command, I get a black border on the right side of the label, see attachment 2. The black border is seen both in the web interface preview and on the printed label.

       

      What am I doing wrong? I use a ZPL420 with Firmware V75.20.10Z.