App crashes when running (not debugging)

I am developing and android studio app that should run on a ET50 with android 6. Everything works ok when debugging the app, but it crashes when running it without debug at this line:

10-29 16:10:16.362 6025-6025/com.luceit.bookdigital.local I/ZEBRA_SCANNER: onOpened

10-29 16:10:16.362 6025-6025/com.luceit.bookdigital.local I/ZEBRA_SCANNER: initializeHardwareScanner

10-29 16:10:16.362 6025-6025/com.luceit.bookdigital.local D/ZEBRA_SCANNER: 1

private void initializeHardwareScanner() {

  LogUtil.i(TAG, "initializeHardwareScanner");
  try {

   if (scanner == null) {

  LogUtil.d(TAG, "1");
   EMDKBase emdkBase = this.emdkManager
   .getInstance(EMDKManager.FEATURE_TYPE.BARCODE);
   LogUtil.d(TAG, "2");

   barcodeManager = (BarcodeManager) emdkBase;

No log after that line. I am currently using 7.0 version of the emdk.

implementation 'com.symbol:emdk:7.0.0'

What can I do??

I´m in a hurry

Thanks

Fernando del Caz
apply plugin: 'com.android

apply plugin: 'com.android.application'
apply plugin: 'org.greenrobot.greendao'
apply plugin: 'io.fabric'
android {

  compileSdkVersion 28
   defaultConfig {

   applicationId "com.XXXX"
   minSdkVersion 22
   targetSdkVersion 28
   versionCode 1
   versionName "1.0"
   testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
   vectorDrawables.useSupportLibrary = true
   project.ext.set("archivesBaseName", "XXXXl-v" + defaultConfig.versionName + "_" + defaultConfig.versionCode)

  resConfigs "en", "es"
   multiDexEnabled true
   }

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments