Image printing prints huge blank space before printing image

We are using Zebra ZQ 320 connecting via Bluetooth External framework for iOS, we are trying to print an image but the printer adds huge white spaces before printing an image. Even the sample code prints the same thing . Could you please let us know what we need to do to get rid of this blank spaces ?

Anonymous (not verified)
Make sure that the media type

Make sure that the media type is set proper on the ZQ320 printer. You can do that with the following SGD.

! U1 getvar "media"

Make sure that the media.type is set to "journal" instead of "label" if you are not using label media. In addition, check the setting of the zpl.label_length. If zpl.label_length is not set properly, you would see a big gap between the prints. The following two examples do the checking and setting.

! U1 getvar "zpl.label_length"

! U1 setvar "zpl.label_length" "150"

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Dmitry Prokhorov
Hello Liji,Could you please

Hello Liji,

Could you please provide your ZPL code? Also it worth to perform a following SGD command and share complete result here:

! U1 getvar "allcv"

Here is information on how to capture report properly:

Using the SGD Allcv Command ! U1 getvar "allcv" <CR>

Also you may find this response useful:

Dmitry Prokhorov

Software Engineer, Kutir Mobility

Posted on behalf of Zebra Technologies

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments