ZT220 print area issue

Hi.

Why there is unprintable fields (5mm) on left and right sides? We using 60mm width labels with this printer.

issue.jpg

I was trying sending commands from PC: "Reset printer" and "Load factory defaults" - thats change nothing. Configuration label (printed even from printer itself, not from PC) is also printing with such fields.

What should I do to make the printer use full width?

Dmitry Prokhorov
Hello Alexander,To figure out

Hello Alexander,

To figure out a possible cause of your issue you may need to analyze an allcv report that could be captured with following SGD command:

! U1 getvar "allcv"

Here is article on how to capture allcv report in a proper way:

Using the SGD Allcv Command  ! U1 getvar "allcv" <CR>

Also, it could be related to ^LS and ^LT ZPL command used:

https://www.zebra.com/content/dam/zebra/manuals/printers/common/programming/zpl-zbi2-pm-en.pdf#page=266

Dmitry Prokhorov

Software Engineer, Kutir Mobility

Posted on behalf of Zebra Technologies

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Dmitry Prokhorov
Hello Alexander,You may also

Hello Alexander,

You may also need to check label settings in a printer driver because it may affect your label printings.

Dmitry Prokhorov

Software Engineer, Kutir Mobility

Posted on behalf of Zebra Technologies

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Alexander --
Update.First of all - the

Update.

First of all - the blank field on the right of label was caused by broken printhead as shown.

fig1.jpg

I switched to absolutely new printhead.

So the issue with left field still present.

I also got the answer from support, they give a link to this article: https://www.zebra.com/us/en/support-downloads/knowledge-articles/unprintable-margin-area-in-a-zebradesigner-created-label.html but it doesn't help. The issue is still there.

fig2.jpg

fig3.jpg

fig4.jpg

I tried to set parameters for label and the the same for driver. Nothing helps.

I have few ZD410 printers - there is no such issues with them, and the labels which printed fine on them - don't print normally on ZT220.

Dmitry Prokhorov can you say - on which line in allcv command output should I pay attention?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Dmitry Prokhorov
Hello Alexander,You may need

Hello Alexander,

You may need to check following SGD setting values:

zpl.label_length

zpl.left_position

ezpl.print_width

ezpl.label_length_max

Also, you may need to check following ZPL commands that could be used in your labels:

^LH

^LL
^LS
^ML

Here is a ZPL manual to check mentioned settings and commands:

https://www.zebra.com/content/dam/zebra/manuals/printers/common/programming/zpl-zbi2-pm-en.pdf

Dmitry Prokhorov

Software Engineer, Kutir Mobility

Posted on behalf of Zebra Technologies

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments