Printer status Malformed after printing Link_OS

Hi,

I am using Link_OS SDK to connect and print labels using a Zebra SDK from iOS app built on Xamarin Forms.

With the new firmware I am getting exception after printing the label at the following point.

IPrinterStatus status = printer.CurrentStatus;

LinkOS.Plugin.ConnectionException: Error getting status: Malformed status response - unable to determine printer status.

Regards,

Ashish

Hello Ashish,

You may need to update your Link-OS Multiplatform SDK  to a most recent version.

In case it will continue suffering from issue you may need to address it to Zebra Technologies support​.

Dmitry Prokhorov

Software Engineer, Kutir Mobility

Posted on behalf of Zebra Technologies

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Hi Dmitry,

Thanks for the reply. I have already posted the question to Zebra Supports and was redirected here from them .

The updation might take some time as the implementation is not the same as the older LinkOS, is there anything that can be done to fix this ?

After I get a malfunction status I have to restart the printer only after that it starts printing.

Ashish

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Hello Ashish,

Most of all it looks like SDK issue or printer firmware issue. You also may need to check your printer firmware and update it to a most recent version.

It's hard to be more specific due to lack of details. I would be nice to know:

1) A model of your printer

2) Version of printer firmware

3) Version of LinkOS SDK used

In case your printer has support for "allcv" SGD command it might be useful to capture allcv report with a following command, and to share result here as a txt file:

! U1 getvar "allcv"

Here is an article on how to properly capture an allcv report:

Using the SGD Allcv Command  ! U1 getvar "allcv" <CR>

Dmitry Prokhorov

Software Engineer, Kutir Mobility

Posted on behalf of Zebra Technologies

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Hello Dmitry,

The details you asked are as follows :

1) A model of your printer : Zebra ZD420 300dpi

2) Version of printer firmware : V84.20.15Z

3) Version of LinkOS SDK used : 1.2

And I didn't got any response after sending the command you mentioned.

Meanwhile, I was trying out the latest version of Zebra.Printer SDK, when I try to store image to the printer using StoreImage method it is taking alot of time like 7-10 sec to store it on the printer for a  55 kb picture. The same method used to store the image like a flash with the LinkOS _SDK.

Regards,

Ashish

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Hello Ashish,

What it your printer model? Could you please to share a source code that produces an error?

Dmitry Prokhorov
Software Engineer, Kutir Mobility
Posted on behalf of Zebra Technologies

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’