Scanner fails to connect with app after connecting to other scanner


Audience

I'm connecting a CS4070 scanner (let's say Scanner-1) with scanner control app on Android via Bluetooth. It gets connected and works properly. Now I connect another CS4070 scanner (Scanner-2) and it too gets connected and works properly. Scanner-1 gets disconnected because of this which is expected.

I leave Scanner-2 connected to scanner control app and after some time Scanner-1 turns off, which is again expected. Now after some time, I turn Scanner-1 back on while scanner control app is connected to Scanner-2. I hear the connection beep on Scanner-1 as it turns on but scanner control app is connected to Scanner-2 still.

And now even if I try to connect to Scanner-1 explicitly from scanner control app, then it tries to connect but fails to do so. Now please bear in mind that this doesn't happen all the time and happens only with more than one scanner. Most of the times it works correctly. You'll have to do these steps a few times to reproduce this issue.

Submitted by johnwood.scra@… on August 14, 2022 Permalink

It sounds like the app is only able to connect to one scanner at a time. When you try to connect to Scanner-1 while the app is already connected to Scanner-2, it fails because the app is still connected to Scanner-2. This is likely a limitation of the app, and not of the scanners.

Submitted by faiz.waghoo@di… on August 16, 2022 Permalink

Yes I know that the app can only connect to one scanner at a time but however when you connect to Scanner-2 while it is connected to Scanner-1 then it disconnects Scanner-1 first and then tries to connect to Scanner-2. Also when the problem occurs, you can see that Scanner-1 has already been disconnected and yet the app is not able to connect to Scanner-2.

Submitted by faiz.waghoo@di… on August 23, 2022 Permalink

One more observation that I have seen recently is that when this issue happens (app not able to connect to Scanner-1) the Bluetooth LED on Scanner-1 is blinking slowly which means that it is connected but it isn't connected in the app. Bluetooth LED usually blinks fast when the scanner is not connected but in this case I can see it is blinking slowly but it isn't connected to app.
I even checked phone's Bluetooth settings, even there it doesn't show up as connected.

Submitted by Riad Benallou on August 23, 2022 Permalink

I don't have two CS4070 to test but could you make sure that your CS4070 is running the latest firmware and try to disable auto reconnect feature in CS4070 if you still see issues then within scan to connect under settings select "enhanced HID keyboard" instead of default which is "enhanced HID keyboard BLE"

Regards
Riad