DNS not correct resolved intermittent on Android Oreo

Hello

need to get file from local store server - local store server given via DHCP via Primary DNS, Secondary DNS provided for backup if local store server not operating
system works for years with Windows CE (MC32)

now moving to TC51 (02-13-15.00-ON-U19-STD)
https://developer.android.com/reference/java/net/HttpURLConnection is used to request the file

sometimes not the Primary DNS is contacted by the device but the secondary DNS - although primary dns is available

sometimes can not really be defined :
- maybe after a restart of device it works ok again,
- or two restarts
- or there are devices which never show the issue
- or there are stores which have not this issue with all of their devices

also using Chrome Browser it will not resolve the primary dns correct

but when starting worryfree-wifi and do a ping to the DNS Name it will immediately return the correct IP Adress
and AFTER doing ping in worryfree wifi also it is correct resolved inside the app and with the Chrome Browser

in WLAN Info the order of DNS is always given correct.

any ideas are very much welcome !

thx, Christian

Rabeb Othmani
Hi Christian, 

Hi Christian, 
Could you please specify if other devices also behave in the same way? Did the device work normally before? 
If you please can provide any details to be able to reproduce the issue. Thanks! 

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Christian Pollak
this is actually solved

or no longer occurring when the Captive-Portal-Detection is disabled (as the devices have no access to free internet)
testet mc52,57,mc33 and tc56

issue is only occurring on oreo devices but not on marshmallow ...

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Rabeb Othmani
Glad to know it is solved. We

Glad to know it is solved. We will be looking into this anyway to understand what could possibly be causing the problem. 
 

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Christian Pollak
this is still not solved

this issue is intermittent still occurring even if captive portal is disabled

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments