How to upload Thai font to iMZ320.

Hi,

 

can someone advise me how to upload Thai font to iMZ320, so i have license and i newest about this product.

 

i have zebra setup utility.

Anonymous (not verified)
Hi Pattagon,Do you have the

Hi Pattagon,

Do you have the TTF file with the font you want?  You can use the Font Downloader in the Setup Utility to download it.  Do you have any specific questions on how to do so?  The iMZ320 printer must be in ZPL mode to download fonts. 

Robin

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Pattagon Sujiwon
Hi Robin,No, i don't have TTF

Hi Robin,

No, i don't have TTF file.

so i use font Downloader in Zebra Setup Utility to download and convert font ["Angsana new" and select script:Thai ] to iMZ320 but when i select -> Character Range and Size -> no Thai font that i need.

can you advise me step to do ZPL mode to download fonts?

other question is when i need to use license number that i have?

thank you.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
Hi Pattagon,What is the

Hi Pattagon,

What is the license number for?  Is it for the font license?   Setup Utility and Font Downloader do not need a license number. 

My legal disclaimer...By law it is required that you license the font before downloading it, even to a printer.

You can get licensed fonts from a number of sources.  Google has free fonts, but if you need a specific one, Fonts.com has a good selection, or you can just go to the copywriter of the font you need.

To put the printer into ZPL mode, click the printer in the Setup Utility.  Then click "Open Communication with Printer".  You will get a two pane window.  In the top half type the following followed by a carriage return:

! U1 setvar "device.languages" "zpl"

! U1 getvar "device.languages"

I did follow your steps and saw the same thing, I think the issue is that you have to be careful that the size of the font with the characters you select is not larger than the memory card size you selected at card setup.  The iMZ has a large user memory space but you have to specify that when you are setting up the font file. See the image below:

Untitled.png

Hope this helps,

Robin

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Pattagon Sujiwon
Hi Robin,i already try this

Hi Robin,

i already try this way but i can't reach Thai character in my font.

but for this font i can type Thai in Microsoft Word.

where i can type

! U1 setvar "device.languages" "zpl"

! U1 getvar "device.languages"

Thank you

1.jpg4.jpg5.jpg

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
Hi Pattagon,How are you

Hi Pattagon,

How are you trying to "reach the character"?  Are you attempting to print and not seeing it?  Which character (124d)?  I'm trying to recreate the issue.

For setting the printer control language to allow the printer to download the font, follow the steps:

1. In Zebra Setup Utilities, click the printer

2. Click "Open Communication With Printer"

Untitled2.png

3. The communication window will open.  Type the commands.

4. Hit Enter key

5. Click "Send To Printer"

Untitled3.png

6. Check the data received is "hybrid_xml_zpl".

Vote: 
Vote up!
Vote down!

Points: 1

You voted ‘up’


Log in to post comments