App Store rejects my app (all apps must support IPv6)

Hi,

My Rho (RMS 5.4) application has been rejected by apple review process.

the message is:

2. 1 PERFORMANCE: APP COMPLETENESS

We discovered one or more bugs in your app when reviewed on iPad and iPhone running iOS 9.3.4 on Wi-Fi connected to an IPv6 network.

any idea or help will be appreciated.

thanks

Dmitry Soldatenkov
By default network


By default network implementation inside Rhomobile use curl library. Now it is not accessible for AppStore.

So you should switch application to use Apple's system network library.

Add to rhoconfig.txt next lines :

ios_net_curl = false

ios_direct_local_requests = true

In Rhomobile 5.5 we will set this property to false by default, but with previously versions of Rhomobile developers should set this property manually.

Second property needed if VPN or Proxy used on device.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


elie matta
Dear Dmitry,i out the above

Dear Dmitry,

i out the above attributes under rhoconfig.txt but i figure out that the problem occur on ipv4 and ipv6!

can u please explain me ?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Samarn Kumwelo
HI Dmitry,Thank you for you

HI Dmitry,

Thank you for you suggestion.

I added below line in rhoconfig.txt but it does not work for me.

ios_net_curl = false

My rhodes is version 5.0.38

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Alex Epifanov
Hi Samarn,Please provide some

Hi Samarn,

Please provide some details on error you get, is your app rejected by Apple?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Alex Epifanov
Hi all,Setting ios_net_curl =

Hi all,

Setting ios_net_curl = false should enable native iOS networking stack which supports ipv6 out of the box.

Still currently we are getting feedback that there are issues with ipv6 functionality.

Tau Technologies has started research on this issue and has set it to high priority.

We are absolutely targeted to provide full ipv6 functionality in the upcoming RMS 5.5 release ( early September ).

Please also file RMS issues to the Tau support desk at tautechnologies.zendesk.com.

Regards,

Alex.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


elie matta
hi Alex,So we will have to

hi Alex,

So we will have to wait the release of RMS 5.5 to solve this problem ? is there anything we can do as workaround ?

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Alex Epifanov
Hi Elle, General network

Hi Elle,

General network tests show that current RMS 5.5 beta works OK from within IPv6 network. We are now checking Apple app store submission for RMS app, and sumbit issues should be resolved at 5.5 release version. If you have some specific IPv6 connectivity issue please file a ticket at tautechnologies.zendesk.com and provide technical details.

Regards,

Alex.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Alex Epifanov
Hi Adel,Can you please

Hi Adel,

Can you please confirm if setting ios_net_curl=0 resolves the issue with app submission to app store?

Regards,

Alex.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Adel Sari
Hi Alex,i am still using RMS

Hi Alex,

i am still using RMS 5.4,

i've set

ios_net_curl = false

ios_direct_local_requests = true

in rhoconfig.txt as proposed

the local tests was ok.

now i am waiting for Apple Review.

i will keep you posted.

thanks.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Dmitry Soldatenkov
HI,What is config.xml ? May

HI,

What is config.xml ?

May be you mean rhoconfig.txt ?

Config.xml is not supported on iOS ! Config.xml is only for Android and WM and only for few case due back-compatibility.

On iOS you should use only rhoconfig.txt.

P.S.

You can test application for ipv6 compatibility on your side. It is not complicated - Every Mac can share ethernet Internet connection by Wi-Fi and you can setup Wi-Fi network as ipv6 network, See this instruction:

Supporting IPv6 DNS64/NAT64 Networks

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Adel Sari
Hi Dmitry,excuse, i wanted to

Hi Dmitry,

excuse, i wanted to say rhoconfig.txt

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Adel Sari
Hi,i can confirm,my

Hi,

i can confirm,

my application is now ready for sale on App Store.

so making this change on rhoconfig.txt

ios_net_curl = false

fix the problem.

thanks

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments