1 Reply Latest reply on Oct 18, 2016 6:05 PM by TAU TECHNOLOGIES

    Rhoconnect start doesn't work

      Hi

       

      I want to set-up a sync server using RhoConnect. So I've followed the "Getting Started" manual (Rhomobile | RhoConnect Introduction ), installed RhoStudio and created my first RhoConnect application. However

      when I want to start the application, using the command line

       

      rhoconnect start
      

       

      It gives me following error:

       

      rhoconnect start
      C:/RhoMobileSuite5.4.0/ruby/lib/ruby/gems/1.9.1/gems/windows-api-0.4.4/lib/windows/api.rb:333:in `initialize': uninitialized constant Windows::API::Win32 (NameError)
              from C:/RhoMobileSuite5.4.0/ruby/lib/ruby/gems/1.9.1/gems/windows-pr-1.2.5/lib/windows/error.rb:425:in `new'
              from C:/RhoMobileSuite5.4.0/ruby/lib/ruby/gems/1.9.1/gems/windows-pr-1.2.5/lib/windows/error.rb:425:in `<module:Error>'
              from C:/RhoMobileSuite5.4.0/ruby/lib/ruby/gems/1.9.1/gems/windows-pr-1.2.5/lib/windows/error.rb:15:in `<module:Windows>'
              from C:/RhoMobileSuite5.4.0/ruby/lib/ruby/gems/1.9.1/gems/windows-pr-1.2.5/lib/windows/error.rb:14:in `<top (required)>'
              from C:/RhoMobileSuite5.4.0/ruby/lib/ruby/gems/1.9.1/gems/win32-process-0.6.6/lib/win32/process.rb:1:in `require'
              from C:/RhoMobileSuite5.4.0/ruby/lib/ruby/gems/1.9.1/gems/win32-process-0.6.6/lib/win32/process.rb:1:in `<top (required)>'
              from C:/RhoMobileSuite5.4.0/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.11.2/lib/bundler/runtime.rb:91:in `require'
              from C:/RhoMobileSuite5.4.0/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.11.2/lib/bundler/runtime.rb:91:in `rescue in block in require'
              from C:/RhoMobileSuite5.4.0/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.11.2/lib/bundler/runtime.rb:68:in `block in require'
              from C:/RhoMobileSuite5.4.0/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.11.2/lib/bundler/runtime.rb:61:in `each'
              from C:/RhoMobileSuite5.4.0/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.11.2/lib/bundler/runtime.rb:61:in `require'
              from C:/RhoMobileSuite5.4.0/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.11.2/lib/bundler.rb:99:in `require'
              from C:/RhoMobileSuite5.4.0/ruby/lib/ruby/gems/1.9.1/gems/rhoconnect-5.4.0/commands/parser.rb:37:in `execute'
              from C:/RhoMobileSuite5.4.0/ruby/lib/ruby/gems/1.9.1/gems/rhoconnect-5.4.0/commands/parser.rb:180:in `<top (required)>'
              from C:/RhoMobileSuite5.4.0/ruby/lib/ruby/gems/1.9.1/gems/rhoconnect-5.4.0/bin/rhoconnect:21:in `require_relative'
              from C:/RhoMobileSuite5.4.0/ruby/lib/ruby/gems/1.9.1/gems/rhoconnect-5.4.0/bin/rhoconnect:21:in `<class:Execute>'
              from C:/RhoMobileSuite5.4.0/ruby/lib/ruby/gems/1.9.1/gems/rhoconnect-5.4.0/bin/rhoconnect:14:in `<top (required)>'
              from C:/RhoMobileSuite5.4.0/ruby/bin/rhoconnect:23:in `load'
              from C:/RhoMobileSuite5.4.0/ruby/bin/rhoconnect:23:in `<main>'
      

       

      I also tried creating the app using the command line interface and then start it, but that gives the same error. When I execute

       

      rhoconnect redis-start
      

       

      the redis server start fine.

       

      I searched on Google, but didn't really find a solution.

       

      Any ideas?

       

      Thx!

       

      Yannick