TC55 and EHS, not able to change Display Touch Mode

Hi All,

 

we have here some TC55 with EHS 2.5.1 installed.

Does anybody knows why i am not able to change Touch modes settings ?

 

I can switch to Stylus and Finger or Glove and Finger, but after a restart no option has been saved.

 

Does anyone know this problem or maybe have a solution.

 

 

Thank you to all

Anonymous (not verified)
Hi, that's a very strange

Hi, that's a very strange issue.  I have a TC55 here with EHS 2.5 installed so gave it a go but I do not see the issue.

In admin mode I can go to settings --> display and select Touch Mode as 'Glove and finger'.  Resetting the device and re-entering admin mode then settings --> display I see touch mode is still set to be 'Glove and finger'

There are no EHS settings that could be changing the touch mode, so I think we can rule that out. 

- The setting can be changed through the Touch Manager profile: Touch Manager - Zebra Technologies Techdocs , are there any apps on the device that could be calling that profile?  In practice this would either be an app you have written or your device management (MDM) application.

- When you say 'restart', just to confirm this is a standard restart i.e. Power button --> Restart.  Any of the factory reset options would put this setting back to default.

Other than that I can't think what the problem could be, it is conceivable this is a bug in the platform so ensuring you are using the latest OS update available (if possible) is a good idea.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Tomislav Dujlovic
Hi Darryn,sorry for my late

Hi Darryn,

sorry for my late reply i was on week off.

But in this time i found the solution (i hope it).

After double checking the XML file i found this:

Apps_disabled

appliction package="com.android.settings"

I removed it and after this i was able to change the Touch mode and after resett touch mode was still saved.

Regards

Tomi

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
Great that it's now working

Great that it's now working Just to make you aware, I believe removing that configuration would give access to the settings UI to end users, if that's OK.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Tomislav Dujlovic
Okei this could be problem ?!

Okei this could be problem ?! I have to test it, but will it be not enough to set this option system_settings_restricted>1< ??

Regards

Tomi

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Anonymous (not verified)
Yes, system_settings

Yes, system_settings_restricted would be a good option here.  Incidentally, I wrote a blog last week comparing the different ways to lock down your device ( ) but it sounds like you're 99% of the way there now anyway.

Vote: 
Vote up!
Vote down!

Points: 0

You voted ‘up’


Log in to post comments