10 Replies Latest reply on Apr 25, 2017 12:28 PM by Daniel Silva

    Serial Comm on MC92

    Jessie Streater

      I have a MC92N0 that originally came with Windows Mobile 6.5.3 and custom piece of equipment that connects to the RS232.  Everything worked well on WM but there was a desire to change the OS to Android.  After some discussion with a Zebra representative it was concluded that I should be able to change the OS to Android KitKat without too much headache.  Most of the EMDK seems to work fairly well but any attempt to use the SerialComm API causes it to crash.  I've traced through the program line by line and it successfully opens the EMDK but crashes on the following line.

       

      serialComm = (SerialComm) this.emdkManager.getInstance(FEATURE_TYPE.SERIALCOMM);

       

      Any thoughts and ideas on how to resolve this would be greatly appreciated!

        • Re: Serial Comm on MC92
          Pietro Francesco Maggi

          Hi Jessie,

          have you updated the EMDK runtime on the MC92 KK?

           

          The Serial Comm API has been introduced in one of the latest releases and you may need to install a newer runtime on the device as explained in the docs:

          Configuring A Device - Zebra Technologies Techdocs

           

          ~Pietro

            • Re: Serial Comm on MC92
              Jessie Streater

              Hi Pietro,

              Thank you for your quick response!

              I ran the "Device Runtime Deployment" and it installed the EMDK 6.3.23 UpdateApp but the app fails.  While connecting to the update installer service it gives the following error...

              "Not allowed to bind to service Intent {act=com.motorolasolutions.emdk.proxyframework,iPrivilagedCommandRunner}"

              Thoughts?

                • Re: Serial Comm on MC92
                  Jessie Streater

                  I pulled the MLogs during the time of the crash.  I was hoping this would help in determining the root cause of the EMDK Update Service Crashing. 

                   

                  04-25 07:51:09.804   480   699 I ActivityManager: START u0 {act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=com.symbol.emdkosupdater/.MainActivity} from pid 823

                  04-25 07:51:09.968  1894  1894 D android.widget.GridLayout: vertical constraints: y1-y0>=644, y2-y1>=0, y2-y0<=428 are inconsistent; permanently removing: y2-y0<=428.

                  04-25 07:51:10.070  1894  2431 D dalvikvm: GC_FOR_ALLOC freed 387K, 14% free 3266K/3768K, paused 23ms, total 23ms

                  04-25 07:51:10.125  1894  2431 D Praveen : versionValue 4.4.4 nodeorg.apache.harmony.xml.dom.ElementImpl@419e2a68OS4.4.4

                  04-25 07:51:10.125  1894  2431 D UpdateConfig: /enterprise/usr/emdkosupdateconfig.xml does not exists. Default config will be used.

                  04-25 07:51:10.125  1894  2431 D Praveen : SDK_Version=19 false

                  04-25 07:51:10.132  1894  2431 W ContextImpl: Implicit intents with startService are not safe: Intent { act=com.motorolasolutions.emdk.proxyframework.IPrivilegedCommandRunner } android.content.ContextWrapper.bindService:517 com.symbol.emdkosupdatelib.UpdateManager.bindToPrivilegedCmdRunner:235 com.symbol.emdkosupdatelib.UpdateManager.startDeviceUpdate:154

                  04-25 07:51:10.132   480   770 W ActivityManager: Permission Denial: Accessing service ComponentInfo{com.motorolasolutions.emdk.proxyframework/com.motorolasolutions.emdk.proxyframework.PrivilegedCommandRunnerService} from pid=1894, uid=10105 requires com.motorolasolutions.emdk.proxyframework.permission.BIND_PRIVILEGED_COMMAND_RUNNER