2 Replies Latest reply on Jun 24, 2017 11:46 AM by Ahmed Cogenli

    IPP with CUPS

    Ahmed Cogenli

      Hello all,

       

      We are currently building a fully automated Inventory and Fulfillment Management system, we are using ZT420 printers to print labels directly from our cloud web app, I was able to add ZT420 as a raw printer in CUPS but whenever I try to send something from CUPS to ZT420, ZT420 startes to act weird, front panel display starts to flicker and printer tries to switch Ribbon mode, even if we use direct thermal. Unfortunately default printer options are not visible under RAW printer so we can not adjust any printer option. We are using Socket Connection for this setup.

       

      I was also able to add ZT420 as a regular Zebra ZPL printer under CUPS, with again socket connection, which works fine, prints fine but very slow most probably due to socket connection, print only 1 4x6 label each 3 seconds. Is there anyway to speed up this printing with Socket?

       

      I also tried IPP protocol with this: ipp://xxxxxx:631/resource?waitjob=false

      CUPS adds the printer but printer doesn't print anything, CUPS says Pending for printer.

       

      As far as I know, ZT420 supports IPP, do we need to enable anything to connect with IPP?

       

      Please let me know what I am missing here,

       

      Thanks in advance,

       

      -Ahmed

        • Re: IPP with CUPS
          Samantha Corn

          Hi Ahmed,

           

          You are correct that the ZT420 can printer faster. It should be capable of printing 12 in/sec.

           

          You actually are able to adjust the printer settings through a regular Zebra printer in the CUPs driver. To do this, create a .txt file with the commands to configure the printer. You can use any SGD or ZPL commands in this file. You can try this command to increase the print speed:

           

          ! U1 setvar "media.speed" "up"

           

          The "up" increments the speed of the printer by one. your can use "down" to increment it down, or a numerical value "2" through "12". You can also use the follwing commands to set the printer to it's factory defaults, if that's what you want to do:

           

          ! U1 setvar "device.restore_defaults" "all"

          ! U1 setvar "device.reset" ""

           

          A carriage return after all commands are necessary. Then, use the Terminal and the following command to send the file to the printer raw:

           

          lp -o raw -d printerNameInCUPs fileName.txt

           

          Hope this helps,

          Samantha

            • Re: IPP with CUPS
              Ahmed Cogenli

              Hi Samantha,

               

              Thanks for your reply,

               

              I will try your suggestion, however this is still Socket connection and we do not have any speed problem with printing RAW, it is already fast but giving a weird problem, printer LCD starts to flicker and printer doesn't respond any other regular prints until a full hard restart. ZPL above might help, I will give it a try.

               

              When printer gets crazy gives this error: WARNING RIBBON IN

              I do many things to get rid of this message, it doesn't print anything until this warning is gone.

               

              I still want to test the IPP connection with ZT420, it seems to be the best option and I still can not figure out how to connect CUPS to ZT420 with IPP, how you tried this before?

               

              Thanks,