0 Replies Latest reply on Nov 2, 2017 2:50 PM by Cameron Banga

    Line mode and null characters

    Cameron Banga

      Hello everyone.

       

      I'm trying to migrate our printers to a new model. For a considerable period of time, we've been using an LP 2824 Plus printer, connected via a serial port to a PLC. This has worked great, and we have the printer set to EPL mode, and then we use a PC and use the "Switch to line mode" command under Printing Preferences Tools, and this works great.  However, the LP2824 has been discontinued, and we can't find any readily available in the quantity we need.

       

      The problem I have is, we ideally need to keep a compatible configuration, as we have many installations in the field, and a PLC re-program/replacement is not feasible, so the existing printer code must continue to work.

       

      We have two printers we are attempting to migrate to, and I think we would be fine with either at this point. Right now in testing, I have the TLP 2824 Plus, and the ZD410.

       

      The TLP 2824 Plus has also been discontinued I believe, but we see many more through our supply channels, so we're comfortable with it if we can make it work. But the problem with this printer is, I can't seem to get it to support Line mode. I've attempted to set it every way I can find, but it seems to not be sticking. I did find one technical document that mentioned that Line Mode is not supported on the Direct Therma printers, which I believe includes this model. I'm mostly curious as to why this is the case technically, as the LP and TLP seem to be nearly identical with respect to specifications/drivers, and if there would be even a remote chance of an no longer supported method to make this work, etc?

       

      The ZD410 would be a better printer for us, more likely, but it has a couple weird caveats that make it a dealbreaker. First and foremost, we have a field where the user can type in a product name. This product name is stored as ASCII text and then sent to the printer. If the user does not enter a product name (which is very common), the product name is empty, but the command to print it is still run. This worked fine on the LP 2824 Plus, but on the ZD410, it prints a strange double zero character (looks kinda like this, but flipped ☍). From what I can tell/guess, this could be the character assigned/displayed for a NULL character on the Zebra printer, which is probably what is being received by the printer. This also occurs if the user enters a product name that does not fit the width of the screen (we print 24 characters across), so if they name is less than 24 characters, these ☍ characters fill the rest of the line.

       

      The same program ran great on the LP2824, but this is our biggest deal breaker so far. Is there a way to configure/send a setvar or something to the printer, that would ignore/not print this character when the name is blank? I'm also seeing an issue where a specific line is always truncated and only the bottom half/third of the line seems to be printed. This may have to do with the lack of a proper return on the line before, or after or something like that? I'm not sure.

       

      Anyways, if anyone has any help/direction, I'd love the help. I've spent yesterday and today reading the 1486 page ZPLII programming guide, the equally riveting EPL guide, and any other resource I can find.